Server Error in '/Altiris/ClientTask/Server' Application

Article:TECH36722  |  Created: 2007-11-02  |  Updated: 2007-11-06  |  Article URL http://www.symantec.com/docs/TECH36722
Article Type
Technical Solution


Issue



https://localhost/Altiris/ClientTask/Server/Register.aspx

Server Error in '/Altiris/ClientTask/Server' Application.

Server cannot access application directory 'G:\Altiris\Client Task Management\ServerWeb\'. The directory does not exist or is not accessible because of security settings.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Web.HttpException: Server cannot access application directory 'G:\Altiris\Client Task Management\ServerWeb\'. The directory does not exist or is not accessible because of security settings.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

 
[HttpException (0x80004005): Server cannot access application directory 'G:\Altiris\Client Task Management\ServerWeb\'. The directory does not exist or is not accessible because of security settings.]
   System.Web.HttpRuntime.EnsureAccessToApplicationDirectory() +72
   System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +263
[HttpException (0x80004005): ASP.NET Initialization Error]
   System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +983
   System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +128

Environment



Notification Server 6.0 SP3
Task Management 6.0.1365

Cause



This issue has been found to happen during the installation of the product due to IIS Security restrictions where IIS is configured to force secure communication (SSL). When IIS is configured this way, the following directory will not be created during the installation:

'<DRIVE>:\Altiris\Client Task Management\ServerWeb\'


Solution



Take the steps below to repair Task Management and its components:

  1. Run inetmgr, and go to Default Web Site. Right-click and choose Properties > Directory Security > Secure Communications > Edit.
  2. Disable the “Require secure channel (SSL)”.
  3. Run iisreset.
  4. Run the C:\Program Files\Altiris\Setup Files\Task Server\Uninstaller.exe.

    Note: We are using the install wrapper to call a hidden MSI and rebuild hidden dependencies.
  5. After the uninstall completes successfully; start the C:\Program Files\Altiris\Setup Files\Task Server\Installer.exe.
  6. Make sure that the Notification Server service is not paused and restart the Altiris Service if needed.
  7. Reset IIS.

Legacy ID



39072


Article URL http://www.symantec.com/docs/TECH36722


Terms of use for this information are found in Legal Notices