After a reboot or restarting the Backup Exec services, the Backup Exec Server Service fails to start with the following error: "An internal error (-14) occurred in object 10."

Article:TECH37233  |  Created: 2007-01-21  |  Updated: 2014-01-08  |  Article URL http://www.symantec.com/docs/TECH37233
Article Type
Technical Solution

Product(s)

Issue



After a reboot or restarting the Backup Exec services, the Backup Exec Server Service fails to start with the following error: "An internal error (-14) occurred in object 10."


Error



An internal error (-14) occurred in object 10.

Checking the Windows Application log shows this error:

An internal error (-14) occurred in object 10.

Event Type: Error
Event Source: Backup Exec
Event Category: (65535)
Event ID: 57802
Date: 2/3/2005
Time: 09:05:56 PM
User: N/A
Computer: SERVER
Description:
The Backup Exec Server Service did not start.  An internal error (-14) occurred in object 10.

 


Cause



The Port 3527 is in use by a different application.


Solution



After a reboot, or restarting SYMANTEC Backup Exec (tm) services, the Backup Exec Server Service fails to start with the following error: "An internal error (-14) occurred in object 10."
 
Port 3527 is reserved by the Backup Exec Message Queue. If this port is in use by another application, install will complete but the Backup Exec Server service will generate the above mentioned error message. Finding the application that is using port 3527 and reassigning that application to another port is preferred; however, you can change the port used by Backup Exec if necessary.
 

 
Additionally the netstat -a -o can be used to find out which port are being used by which process id. The process id can in turn be seen under the Windows Task Manager to find out which application's thread has that process id. The command "-o" is available only on Windows 2003 Family.
 
The Process-id column  is not there by default in Windows Task manager. It needs to be added through View Menu -> "Select Columns" as shown in Figure 1.
 

 
Figure 1
 
 
 

 
To change the port the Backup Exec Message Queue uses :
 
Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.
 
1. Using Regedit or Regedt32, navigate to
     HKEY_LOCAL_MACHINE\SOFTWARE\Veritas\Backup Exec\Server  (BE 10d or below)
     HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Backup Exec\Server  (BE 11d or above) 
 
2. Right-click Server, select New and then select DWORD Value
 
3. Name the key MQPortID, select Decimal as the base  and enter the value of the new port that the Backup Exec Message queue should use for communications
 
4. Restart the Backup Exec services
 
Note: If the server is a Central Administration Server (CASO) or a Managed Media Server (MMS), this port will need to be changed on all servers in which this media server participates.
 

 

 


Supplemental Materials

SourceEvent ID
Value57802
Description

The Backup Exec Server Service did not start. An internal error (-14) occurred in object 10.



Legacy ID



275017


Article URL http://www.symantec.com/docs/TECH37233


Terms of use for this information are found in Legal Notices