DS problem with script job with error common\ipc\TcpSocketIpc.cpp:71 - CTCPSocketIPC::Connect Failed

Article:TECH37932  |  Created: 2007-12-14  |  Updated: 2012-07-21  |  Article URL http://www.symantec.com/docs/TECH37932
Article Type
Technical Solution


Issue



We are doing some DS tests; we are staging Vista machines:

     - Using ghost to deploy the image
     - installing VSA and MSIs

Sometimes (randomly) a machine will fail:

    

In the aclient.log we see:

[11/08/07 10:00:16.221 1524 0] bootstrap.cpp:778 - Error reading input file.
[11/08/07 10:05:37.851 2176 0] UiInitialConnectThread.cpp:107 - CIPCError error connecting, CWinPipeIPC::Connect() pipe error - 2
[11/08/07 10:05:40.956 1296 0] main.cpp:654 - Leaving Main()
[11/08/07 10:08:08.873 1308 0] bootstrap.cpp:778 - Error reading input file.
[11/08/07 10:09:49.915 2120 0] UiInitialConnectThread.cpp:107 - CIPCError error connecting, CWinPipeIPC::Connect() pipe error - 2
[11/08/07 10:09:51.697 1272 0] main.cpp:654 - Leaving Main()
[11/08/07 10:12:26.575 1420 0] bootstrap.cpp:778 - Error reading input file.
[11/08/07 10:13:41.806 116 0] UiInitialConnectThread.cpp:107 - CIPCError error connecting, CWinPipeIPC::Connect() pipe error - 2
[11/08/07 10:13:46.252 1288 0] main.cpp:654 - Leaving Main()
[11/08/07 10:16:18.007 812 0] bootstrap.cpp:778 - Error reading input file.
[11/08/07 10:17:36.442 1428 0] UiInitialConnectThread.cpp:107 - CIPCError error connecting, CWinPipeIPC::Connect() pipe error - 2
[11/08/07 10:17:38.806 1072 0] main.cpp:654 - Leaving Main()
[11/08/07 10:20:05.342 1360 0] bootstrap.cpp:778 - Error reading input file.
[11/08/07 10:36:07.494 848 0] UiInitialConnectThread.cpp:107 - CIPCError error connecting, CWinPipeIPC::Connect() pipe error - 2
[11/08/07 10:36:09.777 1232 0] main.cpp:654 - Leaving Main()
[12/12/07 09:23:45.124 1800 0] bootstrap.cpp:778 - Error reading input file.
[12/12/07 09:27:11.698 240 0] bootstrap.cpp:778 - Error reading input file.
[12/12/07 09:32:42.772 240 0] CDSAgent::ConnectToServer() - exception thrown while trying to connect to the DS.
      File: common\ipc\TcpSocketIpc.cpp, Line: 71, Error Message: CTCPSocketIPC::Connect Failed to connect [12/12/07 09:32:42.772 240 0] bootstrap.cpp:500 unhandled exception thrown
from startup code
      common\ipc\TcpSocketIpc.cpp:71 - CTCPSocketIPC::Connect Failed to
connect
      Value=0, SystemError=0x00002736
[12/12/07 09:32:42.772 2032 0] main.cpp:654 - Leaving Main()
[12/12/07 09:32:42.835 3800 0] bootstrap.cpp:778 - Error reading input file.
[12/12/07 09:32:50.341 2828 0] Toolbox-Main.cpp:103 Toolbox::DoMagic caught an unhandled exception
[12/12/07 09:32:50.341 2828 0] Exception Details: common\util\FileUtils.cpp:136 - Delete failed - target does not exist (error = 3)
[12/12/07 09:32:51.826 2860 0] internal/Configure.cpp:544
Configure::HandleMessage(): about to call Analyze() and RunConfig()
[12/12/07 09:33:03.596 3908 0] UiInitialConnectThread.cpp:107 - CIPCError error connecting, CWinPipeIPC::Connect() pipe error - 2
[12/12/07 09:33:03.705 3788 0] main.cpp:654 - Leaving Main()
[12/12/07 09:33:42.612 456 0] bootstrap.cpp:778 - Error reading input file.
[12/12/07 09:33:43.728 456 0] internal/Configure.cpp:544
Configure::HandleMessage(): about to call Analyze() and RunConfig()
[12/12/07 09:35:02.912 2628 0] UiInitialConnectThread.cpp:107 - CIPCError error connecting, CWinPipeIPC::Connect() pipe error - 2
[12/12/07 09:35:02.943 428 0] main.cpp:654 - Leaving Main()
[12/12/07 09:35:36.222 460 0] bootstrap.cpp:778 - Error reading input file.
[12/12/07 09:36:39.077 3848 0] RequestSendFile.cpp:374 - CRequestSendFile::DoReceiveFile: caught CIPCError exception
      common\ipc\TcpSocketIpc.cpp:71 - CTCPSocketIPC::Connect Failed to connect
      A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
[12/12/07 09:36:39.077 3848 0] RequestSendFile.cpp:249
CRequestSendFile::HandleMessage : Error Receiving file. DoReceiveFile() returned false.


Environment



Deployment Solution 6.8 Service Pack 2.

Windows Vista running the DAgent.


Cause



Based on the information provided by the log file extracts it seem that the DAgent is loosing connectivity with the Deployment Server.

Solution



The problem did no re-occur since the customer logged this incident.

This may have been caused by temporary network issue.


Legacy ID



39764


Article URL http://www.symantec.com/docs/TECH37932


Terms of use for this information are found in Legal Notices