Package Server Agent is not correctly installed on a client system

Article:TECH38159  |  Created: 2007-12-31  |  Updated: 2007-12-31  |  Article URL http://www.symantec.com/docs/TECH38159
Article Type
Technical Solution


Issue



In the Altiris Agent logs for a sytem set up as a Package Server, the following message is found: "Error while downloading package.  No package sources returned by server (-2147023728)."

The information from KB 27161 did not seem to apply in this case.  In the IIS manager, there were no virtual directories under the main Altiris one, and this one did not point to an actual folder on the computer.  This server had previously been installed with the Notification Server software, which was since removed.

In the Altiris Agent, the Package Server Agent was not showing up as an installed agent, although the software task showed as being run properly.  When a run was attempted on it again, it appeared to run but the Altiris logs showed it was already installed so it didn't attempt the run again.

Environment



server: Notification Server 6.0.6074 (SP3 + R6)
Windows 2003 Server

client: Windows 2003 server


Cause



The Package Server Agent software had not been installed properly the first time.

Solution



Manually uninstalled the Package Server Agent since it wasn't showing up in the Add/Remove Program list.  From the Altiris Agent install path,
C:\Program Files\Altiris\Altiris Agent\Software Delivery\{6C821F5E-5BF4-407F-A6FF-ABB85EEE0418}\cache\aexnscpkgsvr.exe /remove

Then, reinstalled the Package Server Agent:
C:\Program Files\Altiris\Altiris Agent\Software Delivery\{6C821F5E-5BF4-407F-A6FF-ABB85EEE0418}\cache\aexnscpkgsvr.exe

Legacy ID



39881


Article URL http://www.symantec.com/docs/TECH38159


Terms of use for this information are found in Legal Notices