CSMXmlParser::ParseXMLString - XML parser error in the NS logs

Article:TECH39608  |  Created: 2008-03-11  |  Updated: 2008-03-11  |  Article URL http://www.symantec.com/docs/TECH39608
Article Type
Technical Solution


Issue



We are recieving high amounts of the following message in our NS Logs:

--- Start of Error message

Log File Name: E:\Program Files\Altiris\Notification Server\Logs\a.log
Priority: 1
Date: 10/03/2008 9:05:47 AM
Tick Count: 496084281
Host Name: AltirisNS
Process: AeXMetricProv.exe (3812)
Thread ID: 412
Module: AeXMetricProv.exe
Source: MetricProvider
Description: CSMXmlParser::ParseXMLString - XML parser error.

Environment



Monitor Solution 6.0
Monitor Solution for Altiris Infrastructure 6.0 (AI Monitor Pack)


Cause



There is one rule in the category checks the a.logs for severity 1 errors. The XML parser errors was due to invalid character existing in the a.logs.

Solution



You can choose to disable the rule.

In the Altiris Console, go to Tasks> Monitoring> Monitor Solution> Manage Monitor Packs> Notification Server 6.0 - Basic> NS Log File> "Warning Alert Severity 1 Error"
On the Notification Server, update the Altiris Agent's configuration.
 
OR

Investigate the cause of the invalid character in the a.logs.
Please refer to Article ID:17586

Legacy ID



40859


Article URL http://www.symantec.com/docs/TECH39608


Terms of use for this information are found in Legal Notices