Cannot gather serial number from Pocket PC Device
| Article:TECH40416 | | | Created: 2008-07-29 | | | Updated: 2008-08-26 | | | Article URL http://www.symantec.com/docs/TECH40416 |
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Problem
Inventory for Pocket PC is not gathering the device serial number on some models.
Environment
Inventory for Pocket PC Solution 6.1.1141
Cause
The code is written to look in several specific places for this value. In some cases, we use system API calls. Some manufacturers store this value in other places.
Solution
The attached hotfix will look for the serial number in the devices registry at HKLM\System\SN, in addition to all current locations.
To apply this hotfix, a new cab file needs to be created to deliver to the PocketPC devices. Please do the following:
- Download and extract the attached file to a temporary location on the Notification Server.
- Make backup copies of PPCAgent.exe and setup.dll found originally in this directory: <%ProgramFiles%>/Altiris/PocketPCAgent/AgentFiles/arm4i .
- Copy PPCAgent.exe and setup.dll from the temporary location into the folder <%ProgramFiles%>/Altiris/PocketPCAgent/AgentFiles/arm4i . Overwrite the existing files, if prompted. (Note : Copy the files to this location only.)
- Execute SetPPCAgentServer.exe from the folder <%ProgramFiles%>/Altiris/PocketPCAgent/AgentFiles or from the OS menu Start->All Programs->Altiris->Solutions->Handheld Management Suite->Set Pocket PC Agent Server.
- Fill in the details about the NS server in the UI. The Notification Server name is required. The port and SSL checkbox are optional, depending on your environment. Do NOT change the values in the "Locations..." text box.
- Click the “Create File(s)” button.
- The PPCAgentWM5.cab file will be created. This file will need to be installed on the device.
- If the Altiris Agent is currently installed on the handheld device, uninstall the agent.
- Install the new build of PPCAgentWM5.cab on the device via the normal installation process or by copying the cab file to the device and running it.
If you have further questions, please contact Symantec Technical Support.
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Legacy ID
43254
Article URL http://www.symantec.com/docs/TECH40416
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