KNOWN ISSUE: DS 6.9 SP1 broke ComputerManagement ASDK call erroring when passing DS Account credentials

Article:TECH40913  |  Created: 2008-11-21  |  Updated: 2009-05-12  |  Article URL http://www.symantec.com/docs/TECH40913
Article Type
Technical Solution

Issue



DS 6.9 SP1 broke ComputerManagement ASDK call erroring when passing DS Account credentials.  Calling ComputerManagementService.DSCredentialsHeader() and passing credentials with DS Security turned on errors witht the following exception:

System.Web.Services.Protocols.SoapException was caught
  Message="Error:\tCould not authenticate Deployment Solution user.\nInvalid credentials were provided for authentication. --> Error:\tCould not authenticate Deployment Solution user.\nInvalid credentials were provided for authentication."
  Source="System.Web.Services"
  Actor="http://<DS>/altiris.asdk.ds/ComputerManagementService.asmx"
  Lang=""
  Node="http://<DS>/altiris.asdk.ds/ComputerManagementService.asmx"
  Role=""
  StackTrace:
       at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
       at DSDelComp.ComputerManagementService.ComputerManagementService.GetComputerID


Environment



ASDK 1.4
DS 6.9 SP1

Cause



AxDsDm.dll not registered in GAC during install/upgrade.

Solution



Workaround:
1) Open up Express share\GAC
2) Open up GAC - Start, Run, “assembly”
3) Drag and drop AxDsDm.dll to GAC
4) start Service “Altiris Deployment Server Data Manager”
5) Restart Service “World Wide Web Publishing”

Fixed in DS 6.9 MP1 and DS 6.9 SP2

Also fixed in build 1.4.209 of the Administrator ASDK downloadable here. 


Legacy ID



44498


Article URL http://www.symantec.com/docs/TECH40913


Terms of use for this information are found in Legal Notices