Error: The Report server cannot process the Report

Article:TECH41410  |  Created: 2009-02-10  |  Updated: 2009-02-10  |  Article URL http://www.symantec.com/docs/TECH41410
Article Type
Technical Solution


Issue



Custom reports created using Report Builder display error messages stating “The report server cannot process the report.  The data source connection information has been deleted. (rsInvalideDataSourceReference)”.


Environment



This issue is isolated to the following environment:

  • IT Analytics 6.x


Cause



IT Analytics allows users to create their own custom reports using Microsoft’s Report Builder authoring tool. Upon creation of a report using Report Builder the user is asked to choose a Report Model for use as a data source.  Each time the report is run this data source is used to retrieve the underlying data for that report.  When a cube is processed the underlying Report Model is deleted and recreated by IT Analytics, causing the reports that have been previously created using Report Builder to break as the data source no longer exists.


Solution



This issue can be resolved by generating your own report model instead of using the one that is automatically generated for you by IT Analytics.  The steps below can be followed to generate this report model at which point any existing reports that are exhibiting this error can be updated to use this newly generated model.  It is also recommended that you use this newly generated model for all future reports created using Report Builder:

 

1.    Connect to Reporting Services in SQL Management Studio.

2.    Expand the Home folder.

3.    Expand the appropriate folder hosting the IT Analytics reports.  By default this is IT Analytics.

4.    Right click on the Altiris Cubes data source and select Generate Model and give it an appropriate name.

5.    Open the SQL Server Reporting Services Report Manager console.

6.    Click on the folder hosting the IT Analytics reports.  By default this is IT Analytics.

7.    Click on a Custom Report that is exhibiting this error.

8.    Click on the properties Tab.

9.    Click on the Data Sources page.

a.    Note the error that the shared data source reference is no longer valid.

10. Click Browse and select the report model you created above.

11. Repeat this for each report that is exhibiting this error.

 

Note:  Regeneration of this model will be required in the event that a cube is installed or uninstalled.

Legacy ID



45544


Article URL http://www.symantec.com/docs/TECH41410


Terms of use for this information are found in Legal Notices