Outbound Helpdesk email fails with error: "Unable to relay"

Article:TECH41413  |  Created: 2009-02-11  |  Updated: 2009-07-14  |  Article URL http://www.symantec.com/docs/TECH41413
Article Type
Technical Solution


Issue



Outbound Helpdesk emails fail to be sent and the following errors are in the a.log files:

Priority: 1
Date: 2/3/2009 11:07:47 AM
Tick Count: 535464875
Host Name: <NS Server Name>
Process: aexsvc.exe (3976)
Thread ID: 6992
Module: AltirisNativeHelper.dll
Source: Altiris.NS.NSMailQueue.HandleEmailError
Description: Failed to send email C:\Program Files\Altiris\Notification Server\Mail\SendMail\NSMail_<guid>.xml. Moving to bad folder C:\Program Files\Altiris\Notification Server\Mail\BadMail\SMTPProtocolException\RecipientAddress ( Unhandled exception. Type=Quiksoft.EasyMail.SMTP.SMTPProtocolException Msg=550 5.7.1 Unable to relay
Src=SMTP.Net
StackTrace=
     at Quiksoft.EasyMail.SMTP.SMTP.a(String A_0, l A_1, ai A_2)
     at Quiksoft.EasyMail.SMTP.SMTP.a(String A_0, EmailMessage A_1, ai A_2)
     at Quiksoft.EasyMail.SMTP.SMTP.Send(EmailMessage MessageObj)
     at Altiris.NS.Utilities.MailStdScripting.SendSMTPSync(MailMessage mailMsg) )


Environment



Notification Server 6.0 SP3 R8
Helpdesk 6.0 SP5

Cause



The SMTP mail server was failing some email addresses as not being "Authoritative"

Solution



Use the Notification Server SMTPLogging feature as described in KB article 2457.

When the SMTP server tried to send to several email addresses, the the error returned was the "Unable to relay."

Configured these addresses as "Authoritative" on the SMTP server and the errors went away; Helpdesk was able to send emails.

Legacy ID



45556


Article URL http://www.symantec.com/docs/TECH41413


Terms of use for this information are found in Legal Notices