KNOWN ISSUE: Agent status not updating after using the /server switch

Article:TECH41458  |  Created: 2009-02-19  |  Updated: 2009-02-24  |  Article URL http://www.symantec.com/docs/TECH41458
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Article Type
Technical Solution


Issue



Agent status not updating after using the /server switch.

Steps to reproduce

1. From command line, open the Altiris Agent.
2. Select the "task status" tab.
3. Open a cmd shell.
4. Navigate to where AexAgentUtil.exe (c:\program files\altiris\altiris agent).
5. Run the command with switch "Server" (i.e. "AexAgentUtil.exe /Server:Other-NS").
On the "task status" page you will notice the "Task Server" field does not update in a timely fashion.

Expected Behavior:
When the NS/task server is changed, the "task status" should display the correct server.

 


Environment



Any Windows OS with the Notification Server 7.0 Agent installed.


Cause



The events that are triggered to switch Notification Servers do not cause the Task Agent to re-download the list of Task Servers.


Solution



Workaround: Use the Reset agent button in the Task Server Agent UI to register with the Task Server and then shutdown and restart the agent.

 


Supplemental Materials

SourceDEFECT
ValueLB 72384
DescriptionLogged in Littlebuggy (Altiris - Lindon, Plymouth) database

Legacy ID



45658


Article URL http://www.symantec.com/docs/TECH41458


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