KNOWN ISSUE: ''Attempted to reference a null interface'', when the NIC is disabled or not ready

Article:TECH41882  |  Created: 2009-04-17  |  Updated: 2009-04-17  |  Article URL http://www.symantec.com/docs/TECH41882
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Article Type
Technical Solution


Issue



When client machines first boot up, if the client task agent starts before the NIC is ready, or if the NIC is disabled, the following error may be thrown in the agent logs:

Module: Client Task Agent.dll
Source: Client Task Agent
Description: CAtrsException exception, error = "Attempted to reference a null interface", OS error = 2147549183, at line 71  
re-throw at CAtrsInterfacePtr::operator->          
re-throw at CTaskAgentBase::IsRegistered         
re-throw at CTaskAgentBase::CheckRegister


Environment



Task Server 6.0 SP2

Cause



The client task agent repeatedly tries to register even if the network interface is not available.

Solution



This issue has been forwarded to development.

As a work around we stopped and restarted all Altiris services on the client.

This cleared the error from the logs.

We did not reboot the client to see if the error returns.

In one situation, the domain of the application identity was changed to a different domain. Looking in Services, it can be seen that many are still associated to the old account. Manually changing these to the new domain and stopping/restarting these services resolved the issue.

Supplemental Materials

SourceDEFECT
ValueLB 77591
DescriptionLogged in Littlebuggy (Altiris - Lindon, Plymouth) database

SourceDEFECT
ValueETK 1650300
DescriptionLogged in Etrack (Symantec) database

Legacy ID



46674


Article URL http://www.symantec.com/docs/TECH41882


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