"No Dell Payload found" error when creating a BIOS Upgrade Policy

Article:TECH41914  |  Created: 2009-04-23  |  Updated: 2009-04-23  |  Article URL http://www.symantec.com/docs/TECH41914
Article Type
Technical Solution

Issue



When attempting to create a BIOS Upgrade Policy you receive a "No Dell Payload Found" error when attempting to apply the policy settings.

Environment



Dell Client Manager 2.2

Cause



Dell Client Manager works by delivering the BIOS payload file rather than the executable file it is packaged in.  In order to do this it must be able to extract the payload file.  Due to apparent changes in the way Dell is packaging at least some of the executable BIOS packages, Dell Client Manager is unable to extract the payload, which results in this error. 


Solution



To resolve this issue the payload file (.hdr) must be extracted manually from the package.

To do this, go to a command prompt.
Change directories to the location where the BIOS files downloaded from Dell are located.
Execute the BIOS file using -writehdrfile command line switch.

For example - E6500_A12.exe -writehdrfile

When this completes you should have a file in the same directory as the executable BIOS package file called E6400A12.hdr.

Back in DCM, point the BIOS upgrade policy to the .hdr file rather than the .exe.  As this is the payload file itself DCM won't have to extract it and you won't get this error.


Legacy ID



46736


Article URL http://www.symantec.com/docs/TECH41914


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