Client Task Server will not reinstall correctly after being removed.

Article:TECH42308  |  Created: 2009-06-16  |  Updated: 2014-05-08  |  Article URL http://www.symantec.com/docs/TECH42308
Article Type
Technical Solution


Issue



If you remove the client task server component from a client (including the NS) and then re-enable that computer to be a task server and attempt to push the client task server package, it will show it had run in the Altiris Agent, but in the details for the package, it doesn't actually run again.


Environment



NS6.x, TS 6.x

NS7.x, TS 7.x


Cause



Because the package by default is set for Run Once ASAP, once the policy has been received and run, it doesn't run again, even if re-sent.  This is by design.  The only time this "design" becomes a problem is if you either do something incorrectly (i.e. remove the agent from the NS) or remove a task server, and then change your mind yet again and re-push it.


Solution



There are two methods to work around this issue.  One is to remove the agent completely and all files, then re-push the agent.  The policy for tracking the installation of the task server should be removed.  However, this should NOT be done on the NS (because the agent should never be removed from the NS), and is the hard way to solve the problem.

A far easier way is to simply reinstall the Client Task Server manually, as follows (the following steps can in fact be performed on the NS and any other site server):

  1. Locate the executable for the installation:
    1. For a 32 bit OS:  \\<NSServerName>\NSCap\bin\win32\x86\ClientTaskManagement\ServerPackage\TaskServerSetup.exe  (If this is a remote task server/site server, you can either go to this location or to the package location from where it was downloaded.)
    2. For a 64bit OS: \\<NSServerName>\NSCap\bin\win64\x64\ClientTaskManagement\ServerPackage\TaskServerSetup_x64.exe
  2. Run the package and agree to all the license prompts.
  3. Choose "Custom Install"
    • If prompted to or given the option to Repair, we'd recommend a full removal rather than a repair.  Please follow the instructions below for that.
  4. On the list of install options, there are 2 items.  Click the top option and select to install all so that all subcomponants are added.  For the HTTP service, make sure it is not installed.
  5. When this is complete, task server should now be functioning.

Optional: Complete Removal

 

Sometimes, we've found that a removal may be necessary to clean up prior to a reinstallation.  If so, please do the following:

  1. Run the setup for the product, found here: \\NSServerName\NSCap\bin\win32\x86\ClientTaskManagement\ServerPackage\ for a 32 bit OS named TaskServerSetup.exe
    • On 64bit OS the file is: \NSCap\bin\win64\x64\ClientTaskManagement\ServerPackage\TaskServerSetup_x64.exe**
  2. Choose to remove the product.
  3. When the installation / removal is complete, verify the services are gone: Object Host and Client Dataloader
    • If they are not removed by the uninstallation, you can remove them by running Service Control in a command prompt, as follows:
          sc delete AtrsHost
          sc delete CTdataload
  4. Restart if necessary (i.e. for removal of the services).

 

** Alternatively, for DS 7.5 you can find this directly on the site server C:\Program Files\Altiris\Altiris Agent\Package Delivery\{840EC827-DBEF-43D7-A3E5-71E96CA4944B}\cache\TaskServerSetup_x64.exe

 



Legacy ID



47656


Article URL http://www.symantec.com/docs/TECH42308


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