KNOWN ISSUE: Add Remove Program Data is incomplete for NS7 Software Discovery or Inventory

Article:TECH42336  |  Created: 2009-06-19  |  Updated: 2009-08-05  |  Article URL http://www.symantec.com/docs/TECH42336
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Article Type
Technical Solution


Issue



Inventory received through a Software Discovery (provided by the Software Management Framework) for Add Remove Programs is incomplete and does not show all entries.


Environment



Symantec Management Platform 7.0 SP1 HF2 and earlier
Software Management Framework 7.0 SP1 (GA release of CMS)

Cause



Only the first run of Software Discovery will send the full details.  All subsequent runs will only send delta changes, so if the system is pointed to a new NS, if the NS is rebuilt, if the computer record was deleted, or any other situation where the data at the server isn't there from the first send, only partial information will be available.

Solution



This issue will be addressed in CMS SP1 as part of Inventory Solution taking over the execution of the Software Discovery.

One way to workaround the issue is to manually go to the Agent computer that is missing the information, delete the cached file found at C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\data\SoftwareCache.xml, and then restart the Agent Service.  The next time the Software Discovery is run on this computer, all of the results will be reported to the NS.


Supplemental Materials

SourceDEFECT
ValueETK 1717771
DescriptionLogged in Etrack (Symantec) database


Legacy ID



47728


Article URL http://www.symantec.com/docs/TECH42336


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