Logs are frequently reporting "Unable to retrieve the list of memberships of the current user."

Article:TECH42342  |  Created: 2009-06-19  |  Updated: 2010-08-21  |  Article URL http://www.symantec.com/docs/TECH42342
Article Type
Technical Solution


Issue



The "Refreshing the cache of local user credentials for '<app identity>" task occurs every hour on the 25's. Occasionally this is failing with "Unable to retrieve the list of memberships of the current user."

Host Name: NS
Process: aexsvc.exe (2088)
Thread ID: 3104
Module: AltirisNativeHelper.dll
Source: Altiris.NS.Security.SecurityTrusteeManager.GetCurrentUserMemberships
Description: Unable to retrieve the list of memberships of the current user. This most likely caused by the security context not having been set. ( Unhandled exception.  Type=System.Exception Msg=Unable to retrieve the user sid from context. This is typically caused by the context not yet being set. Src=Altiris.NS
StackTrace=
   at Altiris.NS.Security.SecurityContextManager.GetTokenUserFromContext()
   at Altiris.NS.Security.SecurityTrusteeManager.GetCurrentUserMemberships() )


Priority: 1
Date: 5/21/2009 5:25:03 AM
Tick Count: 982553281
Host Name: NS
Process: aexsvc.exe (2088)
Thread ID: 3104
Module: AltirisNativeHelper.dll
Source: Altiris.NS.ItemManagement.Item.CanDelete
Description: Failed to check context menu Delete permission for item a0f24b94-571f-4210-b134-3603d077054f. Error: Altiris.NS.Exceptions.AeXException: Unable to determine the effective permissions for the current user on the specified item ('0a2c056c-2143-4e56-af30-0487177d10d3'). ---> Altiris.NS.Exceptions.AeXException: Unable to retrieve the list of memberships of the current user. This most likely caused by the security context not having been set. ---> System.Exception: Unable to retrieve the user sid from context. This is typically caused by the context not yet being set.
   at Altiris.NS.Security.SecurityContextManager.GetTokenUserFromContext()
   at Altiris.NS.Security.SecurityTrusteeManager.GetCurrentUserMemberships()
   --- End of inner exception stack trace ---
   at Altiris.NS.Security.SecurityTrusteeManager.GetCurrentUserMemberships()
   at Altiris.NS.Security.SecurityMonitor.GetEffectivePermissions(Guid itemGuid)
   --- End of inner exception stack trace ---
   at Altiris.NS.Security.SecurityMonitor.GetEffectivePermissions(Guid itemGuid)
   at Altiris.NS.ItemManagement.Item.get_EffectivePermisssions()
   at Altiris.NS.ItemManagement.Item.CheckPermission(Guid Permission)
   at Altiris.NS.ItemManagement.Item.CanDelete()


Priority: 1
Date: 5/21/2009 5:25:03 AM
Tick Count: 982553281
Host Name: NS
Process: aexsvc.exe (2088)
Thread ID: 3104
Module: AltirisNativeHelper.dll
Source: Item Management
Description: Delete Object failed. The object attributes you are trying to delete does not include deletion

Log File Name: a26.log
Priority: 1
Date: 5/21/2009 5:25:03 AM
Tick Count: 982553281
Host Name: NS
Process: aexsvc.exe (2088)
Thread ID: 3104
Module: AltirisNativeHelper.dll
Source: Altiris.NS.ItemManagement.Item.Delete
Description: The caller does not have sufficient permissions to delete the specified item (Item: a0f24b94-571f-4210-b134-3603d077054f)


Environment



NS Sp3 R9

OOB


Cause



This is being caused by the OOB Resource Synchronization schedule possibly running too frequently


Solution



 
The OOB Resource Synchronization process generally takes a long time to run and since we only see these errors occur occasionally it may be that we are overlapping schedules since this is scheduled to run Hourly.  The default schedule is “Daily”.  Backing off to a "Daily" schedule caused these errors to not occur.

Legacy ID



47739


Article URL http://www.symantec.com/docs/TECH42342


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