KNOWN ISSUE: Getting errors in the Application Event Log for upd_rack_enclosure_bay

Article:TECH43175  |  Created: 2009-07-24  |  Updated: 2012-07-21  |  Article URL http://www.symantec.com/docs/TECH43175
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution


Issue



In the Application Event Log on the Deployment Server there's a lot of entries as such:

Event Type: Error
Event Source: Altiris Deployment Server
Event Category: None
Event ID: 1
Date: <m/d/yyyy>
Time: <hh:mm:ss AM/PM>
User: N/A
Computer: <servername>
Description:
Database Error: Procedure or function 'upd_rack_enclosure_bay' expects parameter'@bay_number' , which was not supplied.


Environment



Deployment Server 6.9 SP2

Cause



The stored procedure upd_rack_enclosure_bay in 6.9 SP2 requires 14 parameters, but in previous versions of DS requires 13.  Something in 6.9 didn't get updated to provide the 14th parameter, @bay_number.

It has been discovered that the cause of this is that IBM blade enclosures report the first bay as Slot00 instead of Slot01.

Solution



Symantec has resolved the problem and the fix will be in the next release.

Supplemental Materials

SourceDEFECT
ValueETK 1768359
DescriptionLogged in Etrack (Symantec) database

Legacy ID



48263


Article URL http://www.symantec.com/docs/TECH43175


Terms of use for this information are found in Legal Notices