KNOWN ISSUE: Unhandled PPA exception
| Article:TECH44236 | | | Created: 2009-08-25 | | | Updated: 2009-08-25 | | | Article URL http://www.symantec.com/docs/TECH44236 |
| NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made. |
Problem
When right-clicking on a computer resource and choosing "Manage Users", the following error occurs:
When referring to the Altiris logs, no related errors appear to have occurred.
Environment
- Real-Time System Manager 7.0.1299
- Real-Time Console Infrastructure SP1 7.0.1299
- Pluggable Protocol Architecture SP2 7.0.6455
Cause
1. This condition will occur if you have the Symantec Management Platform Installed to a path which is not the default (e.g. E:\Altiris). This is caused when a repair has been run on "Altiris Pluggable Protocol Architecture" within the Symantec Installation Manager. The repair causes certain registry values to be set to the default path of installation instead of the proper alternate path. This behavior is a defect and has been submitted to development.
2. This error can also be returned if the target computer has the Windows Firewall turned on because the firewall is probably blocking the port through which WMI is attempting to communicate through.
Solution
1a. Modify the following registry values to point to the proper installation path of the Pluggable Protocols:
HKLM\Software\Altiris\PluggableProtocols\BinariesPath
HKLM\Software\Altiris\PluggableProtocols\ConfigPath
Example: If Altiris has been installed to: "E:\Altiris", then these values should be:
BinariesPath: E:\Altiris\Pluggable Protocols Agent\bin
ConfigPath: E:\Altiris\Pluggable Protocols Agent\bin\Config
1b. Either reboot the Notification Server, or run "iisreset" and restart all the Altiris Server services
This issue has been addressed by development and will be resolved in Pluggable Protocol Architecture SP4.
2. If the problem is related to the Windows Firewall being enabled the problem is compounded by the fact that WMI (in operating systems other than Vista) do not have the ability of statically assigning a static port through which WMI can communicate. See KB 41179 for an explanation and possible workarounds.| Source | DEFECT |
| Value | ETK 1810559 |
| Description | Logged in Etrack (Symantec) database |
Related Articles
Legacy ID
48770
Article URL http://www.symantec.com/docs/TECH44236
Terms of use for this information are found in Legal Notices









Thank you.