Microsoft SQL databases are skipped after an upgrade to Backup Exec 10.x or higher

Article:TECH44607  |  Created: 2005-01-31  |  Updated: 2013-01-14  |  Article URL http://www.symantec.com/docs/TECH44607
Article Type
Technical Solution

Product(s)

Issue



Microsoft SQL databases are skipped after an upgrade to Backup Exec 10.x or higher


Error



Database was not found, or could not be accessed.

V-79-57344-5891 - The object was not found, or could not be accessed (MS SQL backup).

Figure 1

 

Figure 2

  
 
The Remote Agent debug log (see Related Document) displays the following message:
 
[2820] 09/16/05 10:33.39 returning msdb
[2820] 09/16/05 10:33:39 Using the Virtual Device mechanism for the backup operation.
[2820] 09/16/05 10:33:39 VDI Open Timeout set to INFINITE
[2820] 09/16/05 10:33:39 VDI Buffer Timeout set to INFINITE
[2820] 09/16/05 10:33:39 Error calling CoCreateInstance: x8007007E
[2820] 09/16/05 10:33:39 Failed the Virtual Device allocation for backup operation.
[2820] 09/16/05 10:33:39 Destroying VirtualDeviceSet
[2820] 09/16/05 10:33:39 Informational, no operation thread handle to close.
[2820] 09/16/05 10:33:39 Informational - cannot deallocate Virtual Device object.
[2820] 09/16/05 10:33:39 LP_ENV::MsgError: error 0xe00084af processing object |msdb

 


 


Cause



1. The error message is a result of a Virtual Device Interface (VDI) failure on the SQL machine. Backup Exec 10.x and above only uses VDI for backups of Microsoft SQL.

2. SQL 2000 is installed on a 64 bit server.

The error message is a result of a Virtual Device Interface (VDI) failure on the SQL machine.  The VDI interface is not the correct version for the 64 bit platform.
3. The SQL VDI files are missing - This has been observerd on SQL 2008R2

Solution



Workaround 1:  
1) Stop the MSSQL Server service (normally named MSSQLServer)
2) Locate the SQLVDI.DLL path (the default path for SQL 2000 is \Program Files\Microsoft SQL Server\80\COM and for SQL 7.0 is \Mssql7\Bin)
3) Type "regsvr32 <path>\SQLVDI.DLL"
4) Start the MSSQL Server Service
 
 
Workaround 2:
Since SQL backups are done using the VDI provided by Microsoft an updated version of VDI is required to complete the backup.
Please apply the following patch from Microsoft to the SQL Server to resolve the issue.
 
Workaround 3: 
 Ensure the following file paths exists
 
-\Program Files\Microsoft SQL Server\80\com\sqlvdi.dll
-\Program Files\Microsoft SQL Server\80\tools\binn\sqlvdi.dll
 
 

 

 


Supplemental Materials

SourceUMI
ValueV-79-57344-5891
Description

Database was not found, or could not be accessed.

 

 



Legacy ID



279955


Article URL http://www.symantec.com/docs/TECH44607


Terms of use for this information are found in Legal Notices