Known Issue: Recovery Solution Portal is blank. Required product is not installed.

Article:TECH46202  |  Created: 2009-10-27  |  Updated: 2009-10-28  |  Article URL http://www.symantec.com/docs/TECH46202
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution


Issue



The Recovery Home page doesn't load any of the pre defined web parts for Recovery Solution. If you edit the portal page the web parts aren't listed in the list of available parts.

Examining the Symantec Management Platform logs shows the following informational message:

Log File Name: D:\Program Files\Altiris\Notification Server\Logs\a6.log
Priority: 4
Date: 10/28/2009 4:23:24 PM
Tick Count: 161222953
Host Name: SERVER
Process: w3wp (55272)
Thread ID: 4
Module: w3wp.exe
Source: Altiris.Console.WebControls.PortalView.CreateWebPartControl
Description: The web part 'Basic Recovery Server Statistics (708dac06-5c11-4b45-b1a2-f508572a8aad)' is hidden from the Portal View as its required product 'b63dca51-fa58-4c0c-b0ef-11d7cbc97934' is not installed


Environment



Recovery Solution 7.0.3333

Symantec Management Platform 7.0.5243 SP2 HF2


Cause



The web parts were defined to check that the Altiris Reporting module is installed. With the release of Symantec Management Platform 7.0 SP2 the product guid for this module was changed. This change causes any web part that is defined to check for this module to no longer display.


Solution



This issue is scheduled to be resolved in a future release of the Symantec Management Platform.

The following steps have been provided as a work around.

1. Download the attached webpart_update.sql.

2. Run the query against your Symantec Management Platform database (Symantec_CMDB by default). This will remove the product requirement from the 6 web parts.

3. Restart IIS on the Symantec Management Platform server.


Attachments

Webpart_update.sql (1 kBytes)

Supplemental Materials

SourceDEFECT
ValueETK 1848671
DescriptionLogged in Etrack (Symantec) database

Legacy ID



49822


Article URL http://www.symantec.com/docs/TECH46202


Terms of use for this information are found in Legal Notices