KNOWN ISSUE: Status of services reported as "Unknown" by AClient/DAgent when viewing node properties

Article:TECH46823  |  Created: 2009-11-12  |  Updated: 2011-08-15  |  Article URL http://www.symantec.com/docs/TECH46823
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution

Product(s)

Issue



When viewing Computer Properties for any node within the Win32 DS console, all services listed under the Services section show a current state of "Unknown".


Environment



This issue has been confirmed using both DAgent and AClient.


Cause



Unknown.


Solution



Deployment Solutions 6.9 SP4 includes an updated axengine.exe to resolve this issue.

For previous Deployment Solutions 6.9 versions, Symantec is providing a new axengine which is attached to this article.  To update to the latest Axengine do the following:

 

1) Stop all Deployment Server services and DS consoles.

2) Rename 'axengine.exe' in the express share (E.g. c:\program files\altiris\express\deployment server) to 'axengine.old'

3) Download 'axengine.exe' attached to this KB to the express share.

 

 

4) Download 'ins_service.sql' attached to this KB.

5) Open SQL Server Management Studio and connect to your SQL Server

6) Select 'File' -> 'Open' -> 'File' and select the 'ins_service.sql' file

7) Change the database drop down to your eXpress database and click 'Execute'

8) Restart all Deployment Server services and DS consoles.


Attachments

axengine.exe (2.4 MBytes)
SQL query
ins_service.txt (528 Bytes)


Supplemental Materials

ValueETK 1892211
Description

Logged in Etrack (Symantec) database


Legacy ID



50117


Article URL http://www.symantec.com/docs/TECH46823


Terms of use for this information are found in Legal Notices