KNOWN ISSUE: Software Portal Request are not executed immediately and wait until the next Client Configuration update

Article:TECH46863  |  Created: 2009-11-15  |  Updated: 2009-11-25  |  Article URL http://www.symantec.com/docs/TECH46863
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Article Type
Technical Solution


Issue



When a user requests software from the Software Portal, the Software is not delivered until the next Configuration Update is made by the Altiris Agent.

The Portal request generates a config request, but the new task hasn't finished being created on the Notification Server.


Environment



Software Delivery Solution 6.1 SP3

Cause



If the Notification Server is under some heavy workload it is possible that the Software Request Task was not completed when the target computer makes it Client Configutation Request.

This causes the agent to not receive the new policy and sets the next client configuration request to be scheduled using the cilent policy interval.

This means that for customers with a 4 hour Client Configuration update interval the Software Request will not start on the requesting computer for 4 hours.


Solution



This problem is resolved in the attached hotfix.

It can be implemented in two dependent steps.

Step 1.Deploy "Altiris.NS.SWDWin32.SWPortal.UI.dll" as the functionality of client side tickle delay is removed. This DLL was changed to implement new thread creation to execute method implemented in [2] for taking care of completion of processing of all threads created for multiple software requests and tickle client only once. [1]:

  1. Go to "\Program Files\Altiris\Software Delivery\bin".
  2. Take a back up of original DLL i.e. "Altiris.NS.SWDWin32.SWPortal.UI.dll_sp3".
  3. Copy "Altiris.NS.SWDWin32.SWPortal.UI.dll" into the folder.

Step 2. Deploy "Altiris.NS.SWDWin32.SWPortal.dll" to use Power Management functions to send a tickle to the computer that made the portal request only once after completion of processing of all software requests [2]:

  1. Go to "\Program Files\Altiris\Software Delivery\GAC"
  2. Take a back up of original DLL i.e. "Altiris.NS.SWDWin32.SWPortal.dll"
  3. Replace "Altiris.NS.SWDWin32.SWPortal.dll" with new DLL.
  4. Go to Start -> Run, type command "cmd" and press enter. It will open command prompt.
  5. Execute below commands on command prompt sequentially:
    cd \
    cd "Program Files\Altiris\Software Delivery\GAC"
    gacutil.exe /i Altiris.NS.SWDWin32.SWPortal.dll

    [Here's an illustration of this]
  6. Restart IIS and Altiris Services.

[1] UI will start new thread/process on server to execute method implemented in [2] which will check completion of processing of all software requests requested by portal user from the requested machine and tickle client only once.

[2] This server side tickle is a new feature and uses the Notification Server built-in Power Management functions to send a tickle to the Altiris Agent on the computer that initated the Software Portal Request. The tickle is sent once the Software Request task is processed. In all cases only one tickle is sent to the Altiris Agent.


Attachments

SWDlibs_servertickle.zip (112 kBytes)

Supplemental Materials

SourceDEFECT
ValueETK 1868821
DescriptionLogged in Etrack (Symantec) database

Legacy ID



50148


Article URL http://www.symantec.com/docs/TECH46863


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