Network Discovery "Create Resources" is not placing created resources in collections to allow for inventory

Article:TECH47176  |  Created: 2009-11-23  |  Updated: 2009-11-23  |  Article URL http://www.symantec.com/docs/TECH47176
Article Type
Technical Solution


Issue



The documentation provided with Inventory Solution for Network Devices 6.x as well as the Best Practices for Inventory for Network Devices both indicate that is it possible to have the product automatically create resources from the network devices that are discovered. What is not made clear in both documents is that discovered resources must still be enabled before they will be available to collections.

To see the source of confusion in the documentation walk through the following steps:
  1. Open NS 6.5 Console > View > Configuration > Configuration > Solutions Settings > Network Discovery > Network Discovery Settings. Read the description underneath the title "Resource Creation Settings:"  
  2. Enable the "Create NS Resources for" and choose NetBIOS Devices, Printers, and Network Devices. 
  3. Choose Apply to save the changes
  4. Run a network discovery scan using either the "Default Scan Group" or a custom group.
  5. When the discovery has completed, click on Solution Settings > Network Discovery > and choose Discovered Devices.
    This will list all of the discovered devices.
  6. Pick a resource from this list and make a note of the hostname or IP address
  7. Now go to the collection "All Network Devices" found under View > Resources > Resource Management > Collections > Network Device Collections
  8. You'll see that the collection has no membership which means no inventory will be run for that resource.

Environment



Inventory Solution for Network Devices 6.x

Cause



By checking the "Create NS Resources for" option and choosing the devices, the NS server has enough information about the Discovered Devices to allow Altiris Asset & CMDB solution to see the resources and interact with them in order to assign cost information, or location information, etc. However none of the discovered resources will be available to any collections.

The confusion comes about because this settings page indicates a device will be automatically created, but on this page, it doesn't explain that those devices will not be available for use until they have been marked as Enabled.

Solution



In order to allow discovered devices to be made available to collections (a requirement in order to run inventory on those devices), the device must first be enabled.

This is done by

  1. Open NS 6.5 Console > View > Configuration > Configuration > Solutions Settings > Network Discovery > Discovered Devices
  2. Highlight 1 or multiple rows in the list of Discovered Devices
  3. Choose Enable

As soon as a device is enabled, it is added to the "All Network Devices" collection and is available for Inventory Scans.

Note that this process has been redesigned for CMS 7. Consult the CMS7 documentation for additional details.


Legacy ID



50294


Article URL http://www.symantec.com/docs/TECH47176


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