KNOWN ISSUE: After installation of CMDB, pushing the Agent to a virtual machine causes duplicates

Article:TECH47278  |  Created: 2009-11-27  |  Updated: 2010-01-28  |  Article URL http://www.symantec.com/docs/TECH47278
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution


Problem



Using the Agent push page to push to a Virtual Machine client after installation of CMDB 7.0 causes the resource to appear as a Virtual Machine as well as a Computer resource.

You may see the following message in the logs:

Attempt to promote existing resource <Resource GUID> failed during message resource save by resource key. Reason: Altiris.NS.Exceptions.AeXException: Target resource type is not compatible with the existing resource type.
   at Altiris.NS.ResourceManagement.Resource.Promote(Guid resourceGuid, Guid targetResourceTypeGuid)
   at Altiris.NS.ResourceManagement.MessagingResource.Save_Impl(Boolean allowUpdate)


Environment



CMDB 7.0

CMDB 7.0 SP1, only when upgraded from CMDB 7.0


Cause



The issue is caused by some incorrect XML used by CMDB to alter the computer resource.  A few attributes of the Computer resource are altered, which cause the NS to identify the Computer resource and the Virtual Machine resource as incompatible to each other for promotion.

Solution



To correct the incorrect attributes for the Computer resource, execute the following SQL:

UPDATE ResourceTypeAttribute
SET IsLocalizable = 0, HasStateXml = 0
WHERE ResourceTypeGuid = '493435F7-3B17-4C4C-B07F-C23E7AB7781F'


Supplemental Materials

SourceDEFECT
ValueETK 1903887
DescriptionLogged in Etrack (Symantec) database


Legacy ID



50354


Article URL http://www.symantec.com/docs/TECH47278


Terms of use for this information are found in Legal Notices