The journal mailbox archiving process halts with the Windows Event ID: 6531 Failed to open Queue: Enterprise Vault Storage Restore Queue in Enterprise Vault for Microsoft Exchange.

Article:TECH49079  |  Created: 2006-01-21  |  Updated: 2007-01-25  |  Article URL http://www.symantec.com/docs/TECH49079
Article Type
Technical Solution


Environment

Problem



The journal mailbox archiving process halts with the Windows Event ID: 6531 Failed to open Queue: Enterprise Vault Storage Restore Queue in Enterprise Vault for Microsoft Exchange.

Error



A connection with Active Directory cannot be established. Verify that there are sufficient permissions to perform this operation. [0xc00e0013] .

Solution



The journaling mailbox archiving task fails with Event Id's 6531and  6651 with description "Failed to open Queue: Enterprise Vault Storage Restore Queue" in Enterprise Vault for Microsoft Exchange. Further investigation can be completed by using the Enterprise Vault Deployment Scanner to troubleshooting this issue.

Cause:

Microsoft Message Queuing (MSMQ) is installed with Active Directory Integration. The root cause can be found by running the Enterprise Vault 6.0 Service Pack 2 Deployment Scanner on the Enterprise Vault server. Please see Related Documents for more information  http://support.veritas.com/docs/282034

The Enterprise Vault Deployment Scanner will display the following error when the MSMQ is installed with Active Directory integration : "Warning  Either MSMQ is installed with Active Directory Integration or some storage directories are on a system drive".

MSMQ was designed to integrate with Active Directory (AD) by publishing information about MSMQ queues in the AD directory structure, which facilitates searching for queues and testing for the presence of queues across the entire domain.  

Resolution:

To resolve this issue, Disable the MSMQ with Active Directory integration, this can be achieved either via "Add/Remove Program" or through the registry .

First Option:

Disable AD integration via Add/Remove Programs to prevent  MSMQ from using AD integration.

1. Navigate to Start | Settings | Control Panel | Add or Remove Programs.

2.  In the Add/Remove Program screen select the option Add/Remove Windows Components (Figure 1).

Figure 1:
 

3. In the Windows Components Wizard select Application Server and then click on the Details button (Figure 2).

Figure 2:
 

4. In the Application Server window select Message Queuing and click on the Details button (Figure 3).

Figure 3:
 

5.  In the Message Queuing window uncheck the Active Directory Integration box and click OK two times to return to original window (Figure 4).

Figure 4:
 

6.  Click on the Next button (Figure 5).

Figure 5:
 

7. The completing configuration screen will appear and the screen will show the completion status (Figure 6).

Figure 6:
 

8. Click on Finish to complete the operation (Figure 7).

Figure 7:
 

9. Restart the server.


Second Option:

Add the DWORD entry named AlwaysWithoutDS under the following registry sub-key to prevents MSMQ from using Active Directory integration

Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application.

1. Open the registry editor and create a DWORD value AlwaysWithoutDS under this key:

HKEY_LOCAL_MACHINHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ \Parameters\Setup.

2. Set the value to 1.

3. Restart the server.

Adding the key should prevent MSMQ from using AD integration, which may cause issues when used on a machine with Enterprise Vault.

Supplemental Materials

SourceEvent ID
Value6531
DescriptionFailed to open Queue: Enterprise Vault Storage Restore Queue.

SourceEvent ID
Value6651
DescriptionFailed to open Queue: Enterprise Vault Storage Restore Queue.

SourceError Code
Value0xc00e0013
DescriptionA connection with Active Directory cannot be established. Verify that there are sufficient permissions to perform this operation.


Legacy ID



285141


Article URL http://www.symantec.com/docs/TECH49079


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