Unable to view archived items via Outlook Web Access (OWA) in Enterprise Vault for Microsoft Exchange.

Article:TECH49352  |  Created: 2006-01-16  |  Updated: 2014-02-27  |  Article URL http://www.symantec.com/docs/TECH49352
Article Type
Technical Solution

Product(s)

Environment

Issue



Unable to view archived items via Outlook Web Access (OWA) in Enterprise Vault for Microsoft Exchange.


Error



Archive item is currently unavailable. "The remote server returned an error: (500) Internal Server Error".


Solution




Overview:

Archived items may not be viewed in Outlook Web Access (OWA) after clicking on the archived item(s). The following error is returned "the remote server returned an error: (500) Internal Server Error".


Cause:

The Enterprise Vault 'anonymous account' may have lost special rights on the Enterprise Vault server, caused by (but not limited to) a GPO (Group Policy Object) being applied to an OU (Organizational Unit) in which the 'anonymous account' resides, that has removed these rights.


Resolution:

Section I

Verify that the Enterprise Vault anonymous account is not located in an OU that has a GPO applied to it.


Section II

To resolve this issue configure the OWA Anonymous user then run the owauser.wsf script.

On Enterprise Vault servers that support connections from OWA 2003 or OWA 2000 servers, follow the instructions in this section to configure a special user account for handling anonymous connections from back-end Exchange servers. This can be completed by creating a "ExchangeServers.txt" file on the Enterprise Vault server. This file contains a list of the IP addresses for all the back-end OWA servers that will connect to the Enterprise Vault server:
 
1. Open NotePad.
 
2. Type the IP address of each back-end OWA server(s). There should be one entry per line. Enter any virtual cluster IP address of the back-end Exchange server.
 
3. Save the file as "ExchangeServers.txt" in the Enterprise Vault installation folder ("<INSTALL_PATH>\Enterprise Vault").
 
4. Close NotePad.



Configure the Anonymous user account for OWA:
 
1. Create a domain user account that will be used as the Anonymous user account for Enterprise Vault (If the account does not exist). This account should be a basic domain account specifically created for Enterprise Vault. A local machine account cannot be used.
 
2. Log on to the Enterprise Vault server as the Vault Service Account.
 
3. Open a command prompt window and navigate to the Enterprise Vault installation folder.
 
4. Type and enter the command line:
 
cscript owauser.wsf /domain:<user's domain> /user:<username> /password:<user's password> /<exchange server name>
 
The script file "owauser.wsf" is installed in the Enterprise Vault installation folder.
 
For domain enter the domain of the Anonymous user account.
 
For username enter the username of the Anonymous user account.
 
For password enter the password of the Anonymous user account.
 
For <exchange server name> you can enter the host name of the back end server.  It may be necessary on 2003 implementations to enter /exch2003, if the back-end OWA server is Exchange 2003, or /exch2000, if the back-end OWA server is Exchange 2000.
 
To display help for the script file type "cscript owauser.wsf /?".
 
5. The progress of the script execution is displayed in the command prompt window. Synchronize all mailboxes and restart the Admin Service when the configuration script completes.
 
A successful execution of the script should look like the following:
 



Legacy ID



285510


Article URL http://www.symantec.com/docs/TECH49352


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