Liveupdate Fails with an Error : "LiveUpdate could not retrieve the update list."

Article:TECH50664  |  Created: 2008-01-31  |  Updated: 2013-01-14  |  Article URL http://www.symantec.com/docs/TECH50664
Article Type
Technical Solution

Product(s)

Issue



Liveupdate Fails with an Error : "LiveUpdate could not retrieve the update list."


Error



Error: "LU1814: LiveUpdate could not retrieve the update list"


Cause



This issue occurs when the client cannot connect to the specified host. The most common reasons for this issue are: 
 
1. Hosts file entries prevent LiveUpdate application connecting to Liveupdate server.
 
2. The S32LUHL1.dll file may be present 
 
3. The Settings.LiveUpdate file is corrupt 

4. Damaged files in the \Downloads folder
 
5. LiveUpdate cannot access the LiveUpdate server.
 
6. Specified LiveUpdate Administrator server is not available to the client.
 
7. Failed install of LiveUpdate.
 
8. Local Permissions 
 
9. The settings for LiveUpdate to connect to the Internet are incorrect.
 
10.Pending Reboot.
 

Solution



Workaround or solution:
 
1. Hosts file entries prevent LiveUpdate from connecting
 
Some worms and Trojans, such as those in the Gaobot family, make changes to the Windows Hosts file. The following are typical entries:
 
127.0.0.1 www.symantec.com
 
127.0.0.1 securityresponse.symantec.com
 
127.0.0.1 symantec.com
 
127.0.0.1 liveupdate.symantecliveupdate.com
 
All such entries should be removed.
 

 2. The S32LUHL1.dll file may be present
 
  • The S32LUHL1.dll file, also known as the LAN HAL, allows legacy versions of LiveUpdate to use UNC connections with LiveUpdate Administrator. This functionality is now included in the LiveUpdate client; hence this file is no longer needed.
  • If this file is present and the necessary settings are not in the Settings.LiveUpdate file, LiveUpdate fails to connect and shows the LU1814 error.
  • Confirm that Windows is set to show all files and file extensions. Then, delete the S32LUHL1.dll file.
     

3. The Settings.LiveUpdate file is corrupted
 
This issue can occur when the Settings.LiveUpdate file becomes corrupted. Delete all copies of the Settings.LiveUpdate file, and then run LiveUpdate again.
  
To delete the Settings.LiveUpdate files
 
1. Start Windows Explorer.
 
2. Confirm that Windows is set to show all files.
 
3. Go to the Documents and Settings\All Users\Application Data\Symantec\LiveUpdate folder.
 
4. Delete all the Settings.LiveUpdate files.
 
Some file names begin with numbers. For example: 1.Settings.LiveUpdate.
 
LiveUpdate reverts to the install defaults if there are custom settings
 
5. Exit Windows Explorer.

 
WARNING: Do not delete the entire Symantec\LiveUpdate folder or the Product.Catalog.LiveUpdate file. If deleted the Symantec\LiveUpdate folder or the Product.Catalog.LiveUpdate file, reinstall all Symantec products for LiveUpdate to work properly.
 

4. Damaged files in the Downloads folder
 
This issue can occur when the files that LiveUpdate uses become damaged. Delete the contents of the Downloads folder, and then run LiveUpdate again.
 
To delete the contents of the Downloads folder
 
1. Start Windows Explorer.
 
2. Confirm that Windows is set to show all files.
 
3. Go to the Documents and Settings\All Users\Application Data\Symantec\LiveUpdate folder.
 
4. Open the Downloads folder.
 
5. Delete the contents of the Downloads folder.
 
In most cases, Autoupdt.trg and Livetri.zip files are present. Do not delete the Downloads folder itself.
 
6. Exit Windows Explorer.
 

5. LiveUpdate is not allowed to connect to the LiveUpdate server
 
This issue can occur if the account that LiveUpdate uses is not authorized to connect to the LiveUpdate server. A LiveUpdate session that is scheduled through the Symantec System Center or scheduled through the User Interface of Symantec AntiVirus uses the System account. If the proxy or firewall is not set to allow the System account to connect to the Internet, the LiveUpdate session can fail. When starting LiveUpdate manually from the Symantec AntiVirus user interface, the LiveUpdate session uses the active user account. 

 
6. Specified LiveUpdate Administrator server is not available to the client
 
The LiveUpdate session can fail for the following reasons:
 
  • Hardware or software stops the client's connection to the LiveUpdate server.
  • The client is not configured correctly to connect to the internal LiveUpdate server.
  • The LiveUpdate Administrator server is offline. 

7. Failed or corrupted installation of LiveUpdate
 
If LiveUpdate files are corrupted or missing, the LiveUpdate session may fail with this error message. To fix the problem, install LiveUpdate again. 

8. Local Permissions
 
The account that initiates the LiveUpdate session must have Full Control permissions to the "Program Files\Symantec\LiveUpdate" folder and to the "All Users\Application Data\LiveUpdate" folder.  

9. The settings for LiveUpdate to connect to the Internet are incorrect
 
By default, LiveUpdate uses the Internet options in the Windows Control Panel.
 
10. Pending Reboot.
 
Schedule a reboot at your earliest convenience and then try again. 
 
Technical Information:
 
The following settings are needed in the Settings.LiveUpdate file for a LiveUpdate client to work with the S32LUHL1.dll file:
 
PREFERENCES\LAN_HAL_PRESENT=YES
 
PREFERENCES\ALL TRANSPORTS AVAILABLE=YES

Supplemental Materials

SourceError Code
ValueLU1814
Description

LiveUpdate could not retrieve the update list



Legacy ID



287232


Article URL http://www.symantec.com/docs/TECH50664


Terms of use for this information are found in Legal Notices