Enterprise Vault PST Migration Fails with Events 6469, 6609, or 6988

Article:TECH51079  |  Created: 2007-01-11  |  Updated: 2014-01-20  |  Article URL http://www.symantec.com/docs/TECH51079
Article Type
Technical Solution


Issue



Enterprise Vault (EV) PST Migration fails with errors, and generates Events with IDs 6469, 6609, and / or 6988


Error



When migrating PST files that are over 1.8GB in size and were created using Outlook 2002, PST migration may fail with following errors.
 
A popup error message comes up which says the following :
 
"There was a migration error. One PST failed migration.
You can try processing it again, after you have corrected the problem.
Once corrected, press Back and then Next to retry it."
 

Some, or all, of the following events might be generated and seen on the EV server

EV event log:
 

Event Type: Error 
Event Source: Enterprise Vault 
Event Category: Migrator Server 
Event ID: 6469 
Description: An exception has occurred. 
[Internal reference CMigrator::StartWorking/ce] 
V-437-6469
 

Event Type: Error 
Event Source: Enterprise Vault 
Event Category: Migrator Server 
Event ID: 6609 
Description: PST file access error occurred 
PST file: <PST file path> 
Account: <account performing migration> 
Reference: SUP/CFE 
V-437-6609
 
 
Event Type: Error 
Event Source: Enterprise Vault 
Event Category: Migrator Server 
Event ID: 6988 
Description: 
A PST failed to migrate because it is too full to process.  Split the PST and attempt to migrate in two parts
V-437-6988

 
To validate if this is the issue a DTRACE is needed, please perform the following steps on the EV server that has generated Event ID 6469, 6609 and 6988 while re-creating the issue.
  • For more information about Symantec Enterprise Vault’s DTRACE Utility please see HOWTO57893.
  • DTRACE the process MigratorServer for no less than 5 minutes while re-creating the issue.
  • Open the log file created and search for either of the following the strings:
  
CMigrator::MarkFolder has started 359 10:46:50.587 [6784] (MigratorServer) <8684> EV:M CMigrator::MarkFolder calling HrMAPIOpenFolderExKVSPstMig 360 10:46:50.587 [6784] (MigratorServer) <8684> EV:M HrMAPIOpenFolderExKvs - Looking for folder [Deleted Items] 361 10:46:50.587 [6784] (MigratorServer) <8684> EV:M HrMAPIOpenFolderExKvsPstMig - Folder Deleted Items exists, opening to look for next folder 362 10:46:50.587 [6784] (MigratorServer) <8684> EV:M CMigrator::MarkFolder getting filter value object 363 10:46:50.587 [6784] (MigratorServer) <8684> EV:M CMigrator::MarkFolder creating hidden message 364 10:46:50.587 [6784] (MigratorServer) <8684> EV:M CMigrator::MarkFolder() - Returned from CreateHiddenMessage() where ArchiveId: 1E04D2861957B7C49B1B53EE080D9FD901110000sevserver and ArchiveFolderId: 1AEEED9B09B47FD4F9784ADA0F80FA8591110000sevserver with [0x8004060C]| 365 10:46:50.587 [6784] (MigratorServer) <8684> EV:M CMigrator::MarkFolder() - Error [0x8004060C] 366 10:46:50.587 [6784] (MigratorServer) <8684> EV:M CMigrator::MarkFolder has quit 367 10:46:50.587 [6784] (MigratorServer) <8684> EV:M CMigrator::SetArchiveFolderVault (Exit) |Exception occurred. [0x80020009] | 368 10:46:50.587 [6784] (MigratorServer) <8684> EV~E Event ID: 6469 An exception has occurred.| [Internal reference CMigrator/SAFV/ce]

 


Cause



Default setting the places a 2GB size limit which applies to ANSI format PST files created using Outlook 2002 and earlier. To work around the issue, the content of the PST file that is failing, must be exported to a Unicode PST, so that the 2GB limit no longer applies.

The Unicode PST can then be migrated by any PST migration method listed in the EV Administrator's Guide. 


Solution



To Determine if a PST File is ANSI or Unicode:
 

1.  Open the PST using Outlook 2003 or 2007 (File | Open Outlook Data File)
2.  Right click on the root of the PST and choose Properties | Advanced
3.  Examine the Format field.
4.  If the format field displays Personal Folders File, then the PST file is Unicode; if the format field displays Personal Folders File (97-2002), then the PST file is ANSI
 


To import an ANSI PST file to a Unicode PST file (for Outlook 2003 and 2007):
 

1. Open Outlook. The version of Outlook must support Unicode e.g. Outlook 2003 or 2007.
2. Go to File - New - Outlook Data File.
3. Select Office Outlook Personal Folders File (.pst). Click OK.
4. Follow the prompt to create a new Unicode *.pst file.
5. Go to File - Import and Export
6. Select Import from another program or file. Click Next.
7. Select the file type to be Personal Folder file (*.pst). Click Next.
8. Select the ANSI version of PST to import. Click Next.
9. Select the root folder to import, and ensure that Include sub folders box is ticked.
10. Select Import items into the same folder in and select the new Unicode PST folder from the drop-down list.
11. Click Finish to complete the export.


Supplemental Materials

SourceEvent ID
Value6609
Description

PST file access error occurred. Reference: SUP/CFE


SourceEvent ID
Value6469
Description

An exception has occurred. [Internal reference CMigrator::StartWorking/ce]


SourceEvent ID
Value6988
Description

A PST failed to migrate because it is too full to process. Split the PST and attempt to migrate in two parts


Legacy ID



287829


Article URL http://www.symantec.com/docs/TECH51079


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