How to use the SGMON utility in Backup Exec 11d for Windows Server (BEWS).

Article:TECH52476  |  Created: 2009-01-07  |  Updated: 2012-06-01  |  Article URL http://www.symantec.com/docs/TECH52476
Article Type
Technical Solution

Product(s)


Issue



How to use the SGMON utility in Backup Exec 11d for Windows Server (BEWS).


Solution



SGMon is a diagnostic tool for Backup Exec. It determines whether processes conflict with the Backup Exec services. SGMon creates debug logs that can help identify possible causes for the backup failures.
 
SGMon gives the ability to view debug output real-time, while the application is running. The user has the ability to pause the output window and review the data in it, or clear the output window together. 

To enable and use SGMon in BEWS 11d:

1. Locate and run SGMon.exe. By default, SGMon is located in the following directory on the Backup Exec media server:
 
\Program Files\Symantec\Backup Exec
 
The following figure displays SGMon: (Figure 1)
 
Figure 1
 
 
 
2. Within Tools > Settings, Application and Debug settings can be specified. Application settings include default settings for the way SGMon processes information. Debug settings include settings for Backup Exec agents, remote agents, Backup Exec server, catalog, device and media, and job engine and remote agent. Debug settings also include settings for specifying notifications options for the SGMon debug jobs and enabling customer feedback logging in SGMon. (Figure 2)
 
Figure 2
 
 
 
3. Click Tool > Sgmon scheduler to set up SGMon to run automatically from a schedule. Schedules can be useful to capture information about the specific scheduled Backup Exec jobs. (Figure 3)
 
Figure 3
 
 
 
4. In SGMon, debug information can be saved either manually or automatically. Manually, only the information that appears in the SGMon console window can be saved. By saving the information automatically, users can have SGMon automatically create a log file and write all the SGMon debug information to that file.
 
a. To manually save debug information from the console window, click File > Save (Figure 4)
 
Figure 4
 
 
 
b. To automatically save debug information to a log file, click Tools > Capture to file (Figure 5)
 
Figure 5
 
 
 
5. In addition, the log files, which are saved from the console window, can be sorted by capture settings. By sorting log files, users can show or hide statements by type. For example, log files can be sorted to view debug statements for only BEUtility or Administration Console.
 

For more information about the new SGMon features, see SGMon help file by selecting Help > Topics. (Figure 6)

Figure 6

 


The SGMon custom help file can also be downloaded from TECH52695 see related articles

 



Legacy ID



289740


Article URL http://www.symantec.com/docs/TECH52476


Terms of use for this information are found in Legal Notices