When attempting to run LiveUpdate from Tools, LiveUpdate from within Backup Exec, error message: LU1835: "Connection to the LiveUpdate server failed" occurs

Article:TECH53376  |  Created: 2007-01-06  |  Updated: 2013-01-07  |  Article URL http://www.symantec.com/docs/TECH53376
Article Type
Technical Solution

Product(s)

Issue



When running LiveUpdate, the error message: "LU1835: Connection to the LiveUpdate server failed. The LiveUpdate server failed to respond in a reasonable amount of time. This could happen because you could not connect to the server, the server is now unavailable, or you became disconnected from the server. Try running LiveUpdate again".


Error



Error: "LU1835: Connection to the LiveUpdate server failed"


Cause



Time-out: The most common cause for this error is slow internet network download speeds.

Rights and permissions: This error message appears if LiveUpdate does not have the correct rights and permissions to pass through the firewall.

Presence of a legacy file: The presence of the legacy file S32LUHL1.DLL can cause this problem

Firewall settings: Blocked access to required ports

Damaged files: This problem can happen when the files that LiveUpdate uses become damaged

Old files in the cache: This error can also happens because previous files were available in the cache.

Live Update Corrupted: This problem can happen when LiveUpdate itself becomes corrupted.

Proxy Configuration:Proxy Server Configured with Auto Script File In Internet Options will cause Problem.

Credential Issue:


Solution



This problem has more than one cause and therefore more than one solution is provided. To fix the problem, try each of the following solutions in the order that they appear.
 
Time-out:
The most common cause for this error is slow internet network download speeds.  This problem can happen when a proxy or firewall holds the content that LiveUpdate requested for longer than LiveUpdate's default time-out value. Because some networks scan files at the perimeter, Symantec added a configurable time-out value to LiveUpdate version 2.5. To learn how to configure the time-out value of LiveUpdate 2.5, read the following document:
 
How to configure the time-out value for HTTP downloads in LiveUpdate version 2.5 and later 
 
Rights and permissions:
This error message appears if LiveUpdate does not have the correct rights and permissions to pass through the firewall. On Windows 2003/XP/2000/NT, LiveUpdate requires administrator-level rights.

Presence of a legacy file:
The presence of the legacy file S32LUHL1.DLL can cause this problem. Look for the S32LUHL1.DLLfile in the following folders and then rename the file, if found: 
  • Program Files\Symantec\LiveUpdate
  • Program Files\SAV 
Firewall settings: 
  • LiveUpdate needs access to the following TCP ports:
  • Port 21 (FTP)
  • Port 80 (HTTP)
  • Port 443 (HTTPS)
  • Disable setting "Deferred scanning for files larger than 2MG" in the FTP area of Firewall.  

Damaged files:
 
This problem can happen when the files that LiveUpdate uses become damaged. Delete the contents of the Downloads folder, and then run LiveUpdate again.
 
To delete the contents of the Downloads folder:
 
 For Windows Server 2003: 
1. Start Windows Explorer. 
2. Confirm that Windows is set to show all files:
3. Go to the Documents and Settings\All Users\Application Data\Symantec\LiveUpdate folder.
4. Open the Downloads folder. 
5. Delete the contents of the Downloads folder.
 
For Windows Server 2008: 

Make sure the hidden files are shown

  1. In windows Explorer click on tools
  2. Folder option and click on view tab
  3. Click on the radio button to show hidden files
  4. Also uncheck the option to "Hide protected Operating system files"
  5. Click on apply and click Ok

Navigate to :-

  1. C:\Program Data\Symantec\LiveUpdate\Downloads
  2. Delete the contents of Downloads folder

Note:  In most cases, Autoupdt.trg and Livetri.zip files are present. Do not delete the Downloads folder itself.
Exit Windows Explorer.
 

Old files in the cache:

LiveUpdate may freeze after downloading 3500 KB within Backup Exec 2010 R2 and Error "LU1835: Connection to the LiveUpdate server failed" pops up.

1. From Control Panel, change LiveUpdate Configuration HTTP settings to "I want to customize my HTTP settings for LiveUpdate". Enter proxy IP and port number.

2. Change the Update Cache size to 30MB and click "remove all files from cache".

3. Run LiveUpdate from Backup Exec again.

Live Update Corrupted:
This problem can happen when LiveUpdate itself becomes corrupted.
Go to Add/Remove Programs and uninstall Symantec Live Update.
Go to ftp://ftp.symantec.com/public/english_us_canada/liveupdate/3.4/, download and install the latest version of Live Update.
Try Live Update once again.

 

Proxy Configuration:
Proxy Server Configured with Auto Script File In Internet Options will cause Problem.
Use HTTP Proxy In Live Update Configuration instead of using Internet Option

http://www.symantec.com/docs/TECH98834

If no proxy is used to connect to internet,

  • Click Start, point to Settings, and then click Control Panel. The Windows Control Panel appears.
  • Double-click Symantec LiveUpdate. The LiveUpdate Configuration dialog box appears.
  • Click the HTTP tab.
  • Select I want to customize my HTTP settings for LiveUpdate
  • Select do not use a proxy server for HTTP connections.

Credential Issue:

Open Backup Exec as 'Run as' Local Administrator in win server 2008, and then download and install the hot fixes from live update. 


Supplemental Materials

SourceError Code
ValueLU1835
Description

Connection to the LiveUpdate server failed



Legacy ID



290975


Article URL http://www.symantec.com/docs/TECH53376


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