Updated hp-patch.pl Installer Patch for 4.1 on HP-UX 11iv2 (9/21/2007)

Article:TECH54337  |  Created: 2007-01-24  |  Updated: 2007-01-24  |  Article URL http://www.symantec.com/docs/TECH54337
Article Type
Technical Solution

Product(s)

Environment

Issue



Updated hp-patch.pl Installer Patch for 4.1 on HP-UX 11iv2 (9/21/2007)

Solution




Note: This is an update for http://support.veritas.com/docs/278400 and http://support.veritas.com/docs/290903 

After clicking on the Download Now link below, move the hp-patch.pl_sep052007.tar_292511.gz file to a new directory and use these commands to unpack the file:

# mv hp-patch.pl_sep052007.tar_292511.gz hp-patch.pl_sep052007.tar.gz

# cksum hp-patch.pl_sep052007.tar.gz
4057091359      3398    hp-patch.pl_sep052007.tar.gz

# gzip -d hp-patch.pl_sep052007.tar.gz

# tar -xf hp-patch.pl_sep052007.tar

# ls

hp-patch.pl


This is the patch README file:

The Volume Manager (VxVM) 4.1 GA package revision 4.1.010 is lower than the Base-VxVM version B.04.10.011

Issue Details:

B.04.10.011 is bundled with the Sept' 06 release of the 11.23 OS (Operating System) and because of this, the installer quits and displays the following error:

ERROR: A later revision (one with a higher revision number) of fileset "VRTSvxvm.VXVM-KRN,r=4.1.010" has already been installed. Either remove this fileset or change the "allow_downdate"  option to "true".

Symantec is providing a new Perl module as a workaround to this installation problem.

Workaround Steps:

     1.  Copy the Perl module hp-patch.pl to /var/tmp
     2.  Run the product installation script with the new module. For example:

          ./installvm -require /var/tmp/hp-patch.pl


The following is an example of output that will be displayed:

Checking VxVM upgrade requirements on system:
Checking VRTSperl package ............................... not installed
Checking VRTSob package ............... version 3.2.532.0.100 installed
Checking VRTSobgui package ............ version 3.2.532.0.100 installed
Checking VRTSvxvm package ................... version 4.1.011 installed
CPI WARNING V-9-10-1371 VxVM version 4.1 includes VRTSvxvm version 4.1.010.  A more recent version of VRTSvxvm, 4.1.011, is already installed on system.
CPI WARNING V-9-10-1400 In this situation, VRTSvxvm version 4.1.011 will not be installed or downgraded on system.
VxVM version 4.1 may not operate correctly with this more recent package. The VRTSvxvm package must be removed manually before version 4.1.010 can be installed.

Do you want to continue? [y,n,q,?] (n) y

Workaround Steps:

     1.  Enter "Y" for the warning message as documented in the technote at http://support.veritas.com/docs/282275 


The installer fails to detect superseded patches for 4.1GA installation and configuration

Issue Details:

The 4.1 product installation scripts for HP-UX do not check for superseded patches.  As a result, the 4.1 installation script will exit if a required patch is not installed, although a superseded patch is installed.

For more details, go to http://support.veritas.com/docs/278400 

Symantec is providing a new Perl module as a workaround to this installation problem.

Workaround Steps:

     1.  Copy the Perl module hp-patch.pl to /var/tmp
     2.  Run the product installation script with the new module. For example:

          ./installsf -require /var/tmp/hp-patch.pl


The following is an example of output that will be displayed when a patch superseding a required patch is installed.

Checking OS version on milrx2600-01 ..................... HP-UX B.11.23
                 :
                 :
Checking for patch PHCO_32387 ............................... installed
Checking for patch PHCO_32388 ............................... installed
Checking for patch PHCO_32389 .............................. superseded


The VxSS configuration fails if the root broker does not belong to HP

Issue Details:

VxSS configuration fails if the root broker has an OS which is not HPUX.

The following error message is displayed:

Enter the name of the VxSS Root Broker system: test.veritas.com
Checking system communication:
Verifying communication with test.veritas.com
...............................ping successful
Attempting remsh with test.veritas.com
...............................remsh successful
CPI ERROR V-9-10-1519 Cannot install Storage Foundation for Oracle RAC on system test.veritas.com as its OS is SunOS and not HP-UX

Symantec is providing a new Perl module as a workaround to this installation problem.

Workaround Steps:

     1.  Copy the Perl module hp-patch.pl to /var/tmp

     2.  Run the product installation script with the new module. For example:

          ./install<prod> -require /var/tmp/hp-patch.pl


The Installvcs script does not detect clusterID 0

Issue Details:

The fix allows the installer to detect 0 and 65535 as valid VCS cluster IDs.

Symantec is providing a new Perl module as a workaround to this installation problem.

Workaround Steps:

     1.  Copy the Perl module hp-patch.pl to /var/tmp
     2.  Run the product installation script with the new module. For example:

          ./install<prod> -require /var/tmp/hp-patch.pl

Attachments

hp-patch.pl_sep052007.tar_292511.gz (3 kBytes)


Legacy ID



292511


Article URL http://www.symantec.com/docs/TECH54337


Terms of use for this information are found in Legal Notices