Symantec Backup Exec System Recovery (BESR) hangs at 5% when backing up systems with non Volume Shadow Copy Service (VSS) compliant databases
| Article:TECH55136 | | | Created: 2010-01-20 | | | Updated: 2012-09-25 | | | Article URL http://www.symantec.com/docs/TECH55136 |
Problem
Symantec Backup Exec System Recovery (BESR) hangs at 5% when backing up systems with non Volume Shadow Copy Service (VSS) compliant databases
Solution
Symantec Backup Exec System Recovery can potentially hang at 5% during the snapshot phase on systems running non VSS compliant databases. Typically the image process cannot be canceled and a system restart may be required.
Cause:
Symantec Backup Exec System Recovery uses the VSS framework to quiesce a database. If a database is not VSS aware, then a hang can potentially occur if a deadlock or access denied condition is encountered. Non VSS compliant databases may include Microsoft SQL versions prior to 2005, Microsoft SQL Server Desktop Engine (MSDE), Microsoft Exchange versions prior to 2003, Oracle, Sybase, and other 3rd party applications.
Solution:
1. Use a batch file to stop SQL or other database services.
2. Once the recovery point is started or the snapshot has been taken, a batch file could be used to restart the services.
Note - stopping the services will ensure pending transactions are committed to the database and a consistent flat-file backup is performed. Once services are stopped, any type of lock or access issues should not be encountered.
Solution:
1. Use a batch file to stop SQL or other database services.
2. Once the recovery point is started or the snapshot has been taken, a batch file could be used to restart the services.
Note - stopping the services will ensure pending transactions are committed to the database and a consistent flat-file backup is performed. Once services are stopped, any type of lock or access issues should not be encountered.
|
|
| Value | 1708620 |
| Description | Backup hangs at 5% |
Related Articles
Legacy ID
293563
Article URL http://www.symantec.com/docs/TECH55136
Terms of use for this information are found in Legal Notices









Thank you.