In a upgraded environment, Backup Exec services fail to start after Intelligent Disaster Recovery (IDR) performed

Article:TECH56424  |  Created: 2007-01-27  |  Updated: 2012-02-22  |  Article URL http://www.symantec.com/docs/TECH56424
Article Type
Technical Solution

Product(s)

Issue



In a upgraded environment, Backup Exec services fail to start after Intelligent Disaster Recovery (IDR) performed


Error



Event ID 58068: The Backup Exec Device and Media Service could not start because the database recovery has failed. Refer to the database recovery log for details.
Event ID 7024: The Backup Exec Device & Media Service service terminated with service-specific error 536928979 (0x2000E2D3).


Cause



This issue is caused because some copies of SQL server are not updated during the upgrade process.

Backup Exec saves its own data which is called BEDB to a special edition of SQL server.

  • Microsoft SQL Server 2000 Desktop Engine (MSDE) is used for Backup Exec 9.1 to 10d.
  • Microsoft SQL Server 2005 Express Edition (SQL Express) is used for Backup Exec 11d or later.

These special editions of SQL servers use master, model and msdb databases and transaction logs as well as standard editions of SQL servers. For performing IDR, copies of the databases and logs are automatically created when installing Backup Exec. However, the copies are not updated for the new edition of the SQL server (SQL Express) during upgrade.

The copies of the databases and logs are named:
  • master$4idr
  • mastlog$4idr
  • model$4idr
  • modellog$4idr
  • msdbdata$4idr
  • msdblog$4idr
The databases, logs and copies are located in C:\Program Files\Microsoft SQL Server\MSSQL$BKUPEXEC\Data\*.* In a default installation of MSDE. This path is maintained after upgrading to SQL Express.
 

Solution



THE ISSUE HAS BEEN RESOLVED IN BACKUP EXEC 2010
 
For older versions of backup exec perform the following steps .

To work around this issue, perform one of the following actions:

1. Before upgrading
 
Delete the copies before performing the upgrade. This will allow the upgrade process to create new copies.
 
Note: The copies are protected by the read-only attribute, which you have to remove when deleting.
 
 
2. After upgrading
 
Delete the copies then apply the latest patches. This will allow the application process to create new copies.
 
 
3. After IDR preformed
 
This procedure recovers the databases and logs from template databases.
 
a. Stop the SQL service named 'SQL Server (BKUPEXEC)'
b. Copy the following files
 
FROM    C:\Program Files\Microsoft SQL Server\MSSQL$BKUPEXEC\Template Data
TO          C:\Program Files\Microsoft SQL Server\MSSQL$BKUPEXEC\Data
 
  • master.mdf
  • mastlog.ldf
  • model.mdf
  • modellog.ldf
  • msdbdata.mdf
  • msdblog.ldf
c. Start the SQL service
 
d. Open command prompt, type the following command
 
OSQL -E -S .\BKUPEXEC
 
e. Copy the following SQL statements and paste these in the OSQL prompt
 
ALTER DATABASE msdb   MODIFY FILE ( NAME = 'MSDBData',  FILENAME = 'C:\Program Files\Microsoft SQL Server\MSSQL$BKUPEXEC\Data\MSDBData.mdf');
ALTER DATABASE msdb   MODIFY FILE ( NAME = 'MSDBLog',   FILENAME = 'C:\Program Files\Microsoft SQL Server\MSSQL$BKUPEXEC\Data\MSDBLog.ldf');
ALTER DATABASE tempdb MODIFY FILE ( NAME = 'tempdev',   FILENAME = 'C:\Program Files\Microsoft SQL Server\MSSQL$BKUPEXEC\Data\tempdb.mdf');
ALTER DATABASE tempdb MODIFY FILE ( NAME = 'templog',   FILENAME = 'C:\Program Files\Microsoft SQL Server\MSSQL$BKUPEXEC\Data\templog.ldf');
ALTER DATABASE model SET READ_WRITE;
ALTER DATABASE model  MODIFY FILE ( NAME = 'modeldev',  FILENAME = 'C:\Program Files\Microsoft SQL Server\MSSQL$BKUPEXEC\Data\model.mdf');
ALTER DATABASE model  MODIFY FILE ( NAME = 'modellog',  FILENAME = 'C:\Program Files\Microsoft SQL Server\MSSQL$BKUPEXEC\Data\modellog.ldf');
 
f. Quit OSQL and restart the SQL server
 
g. Start Backup Exec services

Supplemental Materials

SourceETrack
Value1146308
Description

IDR: Backup Exec services fail to start after IDR recovery when upgraded from 10d or below to 11d.


SourceError Code
Value58068
Description

The Backup Exec Device and Media Service could not start because the database recovery has failed. Refer to the database recovery log for details.


SourceError Code
Value7024
Description

The Backup Exec Device & Media Service service terminated with service-specific error 536928979 (0x2000E2D3).



Legacy ID



295280


Article URL http://www.symantec.com/docs/TECH56424


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