THIRD PARTY: Multiple client backups exit with status 24 when the network is heavily loaded.

Article:TECH56950  |  Created: 2008-01-22  |  Updated: 2014-05-01  |  Article URL http://www.symantec.com/docs/TECH56950
Article Type
Technical Solution


Environment

Subject

Issue



THIRD PARTY: Multiple client backups exit with status 24 when the network is heavily loaded.

NOTE: Backing up a single client at a time is successful.  When all client backups are initiated simultaneously, some clients will exit with status 24. This symptom can be intermittent as well, and possibly during a certain backup window.


Error



EXIT STATUS 24: socket write failed


Environment



- Netbackup 6.5.x clients can be Windows 200x Server or Linux
- Multiple clients backing up to the same tape/disk storage unit at the same time
- For Windows client, it has Windows Server 2003 Scalable Networking Pack installed
 


Cause



Network connection failure (can be due to different causes as specified in solution).


Solution



 
From the Windows 2003 client registry:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
"EnableTCPChimney"=dword:00000001


The following is seen in the client's bpbkar log:
12:44:14.293 AM: [5420.6320] <32> TransporterRemote::write[2](): FTL - SocketWriteException: send() call failed, could not write data to the socket, possible broken connection.
...
12:44:14.309 AM: [5420.6320] <2> tar_base::V_vTarMsgW: INF - EXIT STATUS 24: socket write failed


From bpbrm log:
00:45:14.201 [11553] <2> bpbrm wait_for_child: child exit_status = 82 signal_status = 0
00:45:14.201 [11553] <2> inform_client_of_status: INF - Server status = 24
00:45:14.202 [11553] <2> put_long: (11) network write() error: Broken pipe (32); socket = 7
00:45:14.202 [11553] <16> inform_client_of_status: could not send server status message
...
00:45:18.739 [11553] <2> bpbrm Exit: client backup EXIT STATUS 24: socket write failed


 
Workaround #1:

For Windows 2003 client, disable the TCP Chimney Offload feature if it's enabled on the NIC. To do this, at a command prompt, enter the following or follow the related technote links for more details:
 
 Netsh int ip set chimney DISABLED

Workaround #2:

Reschedule the backups to other time of the day. It is realized that with more backups running simultaneously, the higher chances of this error would occur. Reschedule the backup can reduce the possibility.

Solution:

Most likely NIC (network interface card) related. Contact the hardware vendor of the NIC for the latest updates for their product as a resolution.

The following NICs are known to most likely causing this error:
- Hewlett-Packard NC373i Multifunction Gigabit Server Adapter
- Broadcom BCM5708C NetXtreme II GigE

In some cases, when customer switches to use Intel NIC, the problem disappears right away.

Reference :
http://support.microsoft.com/kb/942861
 





Legacy ID



296341


Article URL http://www.symantec.com/docs/TECH56950


Terms of use for this information are found in Legal Notices