"Access is denied" errors occur when attempting to backup SQL Databases

Article:TECH59280  |  Created: 2008-01-03  |  Updated: 2014-01-14  |  Article URL http://www.symantec.com/docs/TECH59280
Article Type
Technical Solution


Subject

Issue



"Access is denied" errors occur when attempting to backup SQL Databases


Error



V-79-57344-33938 - BackupVirtualDeviceSet::Initialize: CoCreateInstance failure on backup device ''. Operating system error 0x80070005 (Access is denied.)
V-79-65323-18210 - BackupVirtualDeviceSet::Initialize: CoCreateInstance failure on backup device ''. Operating system error


Cause



This error may occur if multiple SQL instances exist on the same server and the SQL services for these instances are running under different service accounts.  For instance, the SQL Server service is running under the Local System account for one instance and another SQL service on the same server is running under a domain administrator account. 

 


Solution



To resolve this issue, make sure all SQL Instances are using the same service account to run.  In addition, make sure this account has sufficient NTFS permissions to access the SQL database files.  For more information, review the related articles below.
 

 

Supplemental Materials

SourceUMI
ValueV-79-57344-33928
Description

Access is denied


SourceUMI
ValueV-79-65323-18210
Description

BackupVirtualDeviceSet::Initialize: CoCreateInstance failure on backup device ''




Article URL http://www.symantec.com/docs/TECH59280


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