"You must reboot this system to complete a previous installation of Remote Agent. After rebooting, run the Setup program again" occurs when attempting to push out or perform a silent (command line) installation of the Remote Agent for Windows Servers (RAWS)

Article:TECH59351  |  Created: 2010-01-15  |  Updated: 2013-05-30  |  Article URL http://www.symantec.com/docs/TECH59351
Article Type
Technical Solution

Product(s)

Issue



This error appears when attempting to push out or perform a silent (command line) installation of the Remote Agent for Windows Servers (RAWS).


Error



You must reboot this system to complete a previous installation of Remote Agent. After rebooting, run the Setup program again.


Cause



This error can occur even after a remote machine has been rebooted and when a silent (command line) install of the Remote Agent for Windows Servers (RAWS) is attempted.


Solution



To resolve the issue:
 
1. Make sure the remote machine has been rebooted.
2.  Confirm TCP Port 10000 is not being used by another application on the remote machine. For more information on this, review the following:

All selections for a remote server in Backup Exec for Windows Servers are unavailable for selection
 
        http://www.symantec.com/docs/TECH24413
Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.

3. If there is a possibility that a previous install of RAWS is still on the remote machine, check the registry on that machine, delete the following key, reboot, and run the install again.
 
HKEY_Local_Machine\SOFTWARE\Classes\SOFTWARE\Symantec\Reboot
 
4. Make sure the console is not locked on the remote machine and that a firewall is not blocking the push install.  If it is, a silent (command line) install may be the only work-around for the issue.  Review the TechNotes in the Related Documents Section below for more information.
  
Note:  When performing a silent install, SETUPAA.CMD is the command to be used, not SETUP.EXE.

Supplemental Materials

SourceUMI
ValueV-225-198

SourceUMI
ValueV-225-191
Description

You must reboot this system to complete a previous installation of Remote Agent. After rebooting, run the Setup program again


SourceUMI
ValueV-225-187
Description

Silent Install is not supported in Maintenance Mode


SourceUMI
ValueV-225-146
Description

You must reboot this system to complete a previous installation of Remote Agent.



Legacy ID



302499


Article URL http://www.symantec.com/docs/TECH59351


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