Lotus Notes backup hangs or fails with 'Error occurred while connecting to Backup Exec Remote Agent'

Article:TECH59355  |  Created: 2008-01-07  |  Updated: 2014-05-12  |  Article URL http://www.symantec.com/docs/TECH59355
Article Type
Technical Solution

Product(s)

Issue



Lotus Notes backup hangs or fails with "Error occurred while connecting to Backup Exec  Remote Agent" and BEREMOTE.EXE terminates in BEDSNOTE.DLL Or The Database server is not responding, Backup set Canceled.


Error



Error occurred while connecting to BEWS Remote Agent

BEREMOTE.EXE terminates in BEDSNOTE.DLL

The Database server is not responding, Backup set Canceled.


Cause



In scenario with a very active Domino server, The database server is not responding may occur when the Backup Exec for Windows Servers connects to Domino server. This may occur when browsing backup selections or The above error appears while backing up a Lotus Domino databases. Additionally, the job log might report a corrupt database or skipped files.
 

When troubleshooting this error,  the Application Event Viewer Log may show the following entry:

Event Type:                  Error
Event Source:               Backup Exec
Event Category:           None
Event ID:                      65215

Description:
The connection to the Lotus Domino server has been lost. The following error was reported: Notes Agent:CLNFileSystem::AttachToDLE - Access Violation Exception Caught. The job that was running on this server has been stopped.


Solution




A workaround for the above issue is to modify the registry on both the media server and the remote Lotus Server per the following:

1. Stop all Backup Exec Services on the media server and the Remote Lotus Server.

Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.


2. Open the Windows Registry Editor by going to START > RUN and typing REGEDT32.

3. Highlight the following registry key: HKLM\software\Symantec\Backup Exec for Windows\Backup Exec\Engine\Domino.

4.Change the value on the right of Enable change Journal to 0 (Default value is 1). (Figure 1).

5.Change the value on the right of Enable notes Database Filtering  to 0(Default value is 1).  (Figure 1).

Figure 1
 

6. Start all Backup Exec Services on the media server AND the Remote Lotus Server.


If the issue is not resolved after making the above changes then deselect the Lotus Folder from the volume level backup as below.(Figure 2.)

 

 
Figure 2.
 
 


Notes:

1) The registry settings mentioned affect only how the Backup Exec for Windows Servers Remote Agent queries for new or changed Domino databases but does not change how those databases get backed up.
2) If the Remote Agent Service has crashed, in some cases the Domino Server console will show repeated entries of Process C:\Program Files\Symantec\Backup Exec\RAWS\belnapi.exe (3632/0xE30) has terminated abnormally. While these entries are harmless, they can be eliminated if desired. To clear these errors from occurring on the Domino console, Domino server will need to be restarted.
 

 



Legacy ID



302505


Article URL http://www.symantec.com/docs/TECH59355


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