An upgrade to a new version of Symantec Backup Exec fails with the error V-225-131: Error in UPG_ migrate function

Article:TECH59393  |  Created: 2009-01-09  |  Updated: 2012-02-01  |  Article URL http://www.symantec.com/docs/TECH59393
Article Type
Technical Solution

Product(s)

Issue



An upgrade to a new version of Symantec Backup Exec fails with the error V-225-131: Error in UPG_ migrate function.

 


Error



V-225-131: Error in UPG_ migrate function

 


Cause



The Backup Exec installation log "bkupinst.htm" reports the above error if the upgrade of the Backup Exec database (BEDB) fails during the installation of the new version of Backup Exec.  There are several root causes that can generate this error during the upgrade process.  The following workaround involves performing a fesh installation of the new version of Backup Exec and then manually upgrading the data from the previous version.  This process resolves many of these upgrade issues.

 
Note:
Do not follow the procedure from this article if either of the following applies:  
  • The Backup Exec Central Admin Server Option (CASO) is installed.
  • The Backup Exec Shared Storage Option (SSO) is installed.


Solution



1. Copy the following Backup Exec directories (folders and files) and save the copies to an alternate location where X: represents the drive where Backup Exec was installed.  By default, this is C:
X:\Program Files\Symantec\Backup Exec\Data
X:\Program Files\Symantec\Backup Exec\Catalogs
 
2. Uninstall Backup Exec and all associated files using the Windows Add or Remove Programs applet in the Control Panel
 
At the Add or Remove Programs dialog box, select Symantec Backup Exec for Windows Servers (Figure 1), and then click Remove.
 
Figure 1
 
  
 
Note: It is not recommended to uninstall the Microsoft SQL MSDE or Microsoft SQL Express instance that Backup Exec uses unless it absolutely necessary to do so.  Removing any of the SQL program files may cause corruption and problems with other services and applications on the computer.
  
3. Install the latest version of Backup Exec for Windows Servers as a fresh install.
 
4. Migrate and upgrade the Backup Exec data from the previous version that was saved in Step 1 above using the Backup Exec Migration Utility (BEMIG.EXE).   Refer to the Related Articles section for links to more information about migrating the Backup Exec data using the BEMIG.EXE utility.

Note that there is a possibility that the error seen during the upgrade is caused by the BEDB being corrupt.  If this is the case, the database migration using the BEMIG utility may not complete successfully.
 

Supplemental Materials

SourceUMI
ValueV-225-131
Description

Error in UPG_ migrate function



Legacy ID



302575


Article URL http://www.symantec.com/docs/TECH59393


Terms of use for this information are found in Legal Notices