When attempting to back up an Oracle database, the error "0xe0001016 - The backup file could not be backed up because there is already a backup file with the same name in the Backup Exec catalog" is reported in the backup job log.

Article:TECH59632  |  Created: 2008-01-15  |  Updated: 2013-03-23  |  Article URL http://www.symantec.com/docs/TECH59632
Article Type
Technical Solution

Product(s)

Issue



When attempting to back up an Oracle database, the error "0xe0001016 - The backup file could not be backed up because there is already a backup file with the same name in the Backup Exec catalog" is reported in the backup job log.


Error



Final error: 0xe0001016 - The backup file could not be backed up because there is already a backup file with the same name in the Backup Exec catalog.

A backup job log displays the above error (figure 1) while backing up an Oracle database and the Archive logs using Symantec Backup Exec Agent for Oracle Server:
 

 

The following errors are reported in the RMAN output section of the job log:
 
released channel: ch0
 
RMAN-00571: ===========================================================
 
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
 
RMAN-00571: ===========================================================
 
RMAN-03009: failure of backup command on ch0 channel at 02/22/2008 13:30:56
 
ORA-19506: failed to create sequential file, name="BE_7vj9bo38_1_1", parms=""
 
ORA-27028: skgfqcre: sbtbackup returned error
 
ORA-19511: Error received from media manager layer, error text:
 
BEError(0xe0001016) The backup file could not be backed up because there is already a backup file with the same name in the Backup Exec catalog.
 
Recovery Manager complete.
 

Cause



  1. This issue occurs if Oracle agent for backup is not properly configured.
     
  2. This issue also occurs when Corba TCP session (Port 5633 on Media Server side by default) is unexpectedly closed.
     
    The Corba TCP session is used for starting a backup or restore job and checking existing catalogs, and no packet is sent on the session during a backup or restore job. In some network environment, the session may be forcibly closed because no packet is sent on the session if a backup job takes a long time. As the result, this issue occurs.
     

Solution





  
 
A.
 
This issue occurs if Oracle agent for backup is not properly configured.
 
Note:-Please check the Related Documents below on "Configuring the Oracle agent on windows computers".
 

 
Solution for cause A:
 
In Backup Exec console Set Tools > Options > Oracle > Modify List to reference the Oracle server 3 times, once via IP Address, once via NETBIOS name, and once via Fully Qualified Domain Name, all 3 entries should use the default account set in Backup Exec under Network--Logon Accounts.

 
B: 

 
This issue also occurs when Corba TCP session (Port 5633 on Media Server side by default) is unexpectedly closed.
 
The Corba TCP session is used for starting a backup or restore job and checking existing catalogs, and no packet is sent on the session during a backup or restore job. In some network environment, the session may be forcibly closed because no packet is sent on the session if a backup job takes a long time. As the result, this issue occurs.
 
 
Solution for cause B:
  
The above mentioned issue has been fixed by way of a hotfix in Backup Exec 12.5. Please refer the Related Documents section below for more information about the hotfix.
 

 
Workaround for cause B:
 
Please check the network environment not to forcibly close the session.
 

 

Supplemental Materials

SourceETrack
Value1221410
Description

Oracle backup is failing with a Corba comm failure and a TAO exception


SourceError Code
Value0xe0001016
Description

The backup file could not be backed up because there is already a backup file with the same name in the Backup Exec catalog


SourceUMI
ValueV-79-57344-4118
Description

The backup file could not be backed up because there is already a backup file with the same name in the Backup Exec catalog



Legacy ID



302884


Article URL http://www.symantec.com/docs/TECH59632


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