When attempting to backup Exchange 2007 resources configured with either Local Continuous Replication (LCR) or Cluster Continuous Replication (CCR), the backup job will intermittently fail with 0xe000fedd, 0xe000037b, 0xe00084af or 0xe000846b errors

Article:TECH61607  |  Created: 2010-01-21  |  Updated: 2013-04-03  |  Article URL http://www.symantec.com/docs/TECH61607
Article Type
Technical Solution

Product(s)

Issue



When attempting to backup Exchange 2007 resources configured with either Local Continuous Replication (LCR) or Cluster Continuous Replication (CCR), the backup job will intermittently fail with 0xe000fedd, 0xe000037b, 0xe00084af or 0xe000846b errors.


Error



1. 0xe000fedd - A failure occurred accessing the object list.
2. 0xe000037b - Using the job settings, Backup Exec attempted to back up
the passive copy of the Exchange database. However, the passive copy was not available after the Microsoft Volume Shadow Copy Service (VSS) snapshot was performed. Try to run the job again.
3. 0xe00084af -  The directory or file was not found, or could not be accessed.
4. 0xe000846b - The resource could not be backed up because an error occurred while connecting to the Backup Exec for Windows Servers Remote Agent.

5. 0xe000037e - Backup Exec attempted to back up a passive copy of the Exchange database using your preferred server job settings. A passive copy was not found, however. Update the preferred server job settings and run the job again.

UMI Code : V-79-57344-65245, V-79-57344-891, V-79-57344-746, V-79-57344-894


Environment



Exchange 2007 resources configured with either Local Continuous Replication (LCR) or Cluster Continuous Replication (CCR).


Cause



1) The 0xe00084af message will only be seen if the Microsoft Exchange properties in the job configuration is set to "Backup from the passive copy Only (job fails if not available)".

2) The 0xe000846b message was seen in an environment where a hardware VSS provider was present.

Solution



 Microsoft has acknowledged the issue. For more information about the issue please contact Microsoft Technical Support.
 
 
Please try the following workarounds.
 
 
Workaround 1:
 
  • Configure an Error Handling Rule in the Backup Exec Console that retries any job that fails with error E000FEDD, E000037B, E00084AF or 0xE000846B.
  • It is suggested that at least 3 retry attempts are made, although the amount is optional.
  • Make sure the rule is set to "Reschedule the job for its next scheduled service".
  • The error codes E000FEDD, E000037B and 0xE000846B can be found under the Error category called "Resource".
  • The error code E00084AF is located in the category called "Job".

Notes:

  • This method allows the backup to complete from the Passive Copy of the Exchange database, but relies on the VSS failure being intermittent so should be tested/monitored carefully.
  • For more information on the use of Error Handling Rules please review the content of the Backup Exec for Windows Administrator's Guide.
  • Depending on the job and media set configuration this workaround could consume extra storage media.
  • Error E00084AF can be caused by other job configurations so this may cause retry attempts against other jobs.

 

Workaround 2:

 
This workaround should be used if setting an error handling rule does not solve the issue.

Configure the Microsoft Exchange settings within the properties of the backup job so that the setting for "If Exchange 2007 backup source is LCR or CCR:" is specified as "Backup from the active copy only (job fails if not available)".

 Also make sure there is enough free disk space on the Exchange server for the snapshot to complete, as it will otherwise fail with the error "Using the job settings, Backup Exec attempted to back up the passive copy of the Exchange database. However, the passive copy was not available after the Microsoft Volume Shadow Copy Service (VSS) snapshot was performed. Try to run the job again."

Supplemental Materials

SourceUMI
ValueV-79-57344-65245
Description

A failure occurred accessing the object list.


SourceError Code
Value0XE000037B
Description

Using the job settings, Backup Exec attempted to back up the passive copy of the Exchange database.


SourceError Code
Value0XE000FEDD
Description

A failure occurred accessing the object list.


SourceUMI
ValueV-79-57344-891
Description

0XE000037b - Using the job settings, Backup Exec attempted to back up the passive copy of the Exchange database.


SourceError Code
Value0XE00084AF
Description

The directory or file was not found, or could not be accessed.


SourceUMI
ValueV-79-57344-746
Description

The job specified that the Microsoft Exchange backup should be made from the passive copy of the database, but the passive copy is currently unavailable.


SourceUMI
Valuev-79-57344-894
Description

e000037e - Backup Exec attempted to back up a passive copy of the Exchange database using your preferred server job settings. A passive copy was not found, however. Update the preferred server job settings and run the job again.
 




Legacy ID



305815


Article URL http://www.symantec.com/docs/TECH61607


Terms of use for this information are found in Legal Notices