Disaster Recovery of a Microsoft Windows 2003 Server fails with the error "The media server was unable to connect to the Remote Agent on machine ServerName.FQDN.Local. The media server will use the local agent to try to complete the operation. Unable to attach to \\ServerName.FQDN.Local\C:".

Article:TECH62466  |  Created: 2009-01-05  |  Updated: 2013-05-30  |  Article URL http://www.symantec.com/docs/TECH62466
Article Type
Technical Solution

Product(s)

Issue



Disaster Recovery of a Microsoft Windows 2003 Server or Microsoft Windows 2008 Server fails with the error "The media server was unable to connect to the Remote Agent on machine ServerName.FQDN.Local. The media server will use the local agent to try to complete the operation. Unable to attach to \\ServerName.FQDN.Local\C:".

The restore may also fail with the error "0xe000848c - Unable to attach to a resource. Make sure that all selected resources exist and are online, and then try again."
 


Error



V-79-57344-3844 - The media server was unable to connect to the Remote Agent on machine \\servername.The media server will use the local agent to try to complete the operation.Unable to attach to \\ServerName.FQDN.Local\C:".


Cause



This issue occurs if the server was backed up using the FQDN (Fully Qualified Domain Name) format instead of the NetBIOS name. As a result on creating a restore job, restore selections will display the server name in FQDN format.

During a disaster recovery process the server is always part of a workgroup and hence does not have any DNS suffix. During the restore Backup Exec tries to connect  to the server by the FQDN and fails to find the server.
 


Solution



To resolve this issue follow the steps given below:

1. Open the System Properties of the Windows Server and click on th the "Computer Name" tab.

2. Click on "Change". The NetBIOS name and the workgroup name will be as shown in Figure 1.

Figure 1.

 


3. Now click on "More" button and enter a "Primary DNS Suffix of this computer" as shown in Figure 2.

Figure 2.

 


Note: The Primary DNS suffix should match with the DNS suffix displayed in restore selections.

E.g:- if the computer name is "ServerName" and the restore selections in the backup set show the name as "ServerName.FQDN.local" then enter the "Primary DNS suffix" as "FQDN.local".


4. Click OK and restart the server.


5. Run a Full System restore from Backup Exec.


Note: The above error also occurs when trying to restore normal files to any drive, if the restore selections are made from the FQDN name.




 

Supplemental Materials

SourceUMI
ValueV-79-57344-33898
Description

The resource could not be restored because an error occurred while connecting to the Backup Exec for Windows Servers Remote Agent.


SourceError Code
Value0xe000848c
Description

Unable to attach to a resource. Make sure that all selected resources exist and are online, and then try again.


SourceUMI
ValueV-79-57344-3844
Description

V-79-57344-3844 - The media server was unable to connect to the Remote Agent on machine



Legacy ID



307395


Article URL http://www.symantec.com/docs/TECH62466


Terms of use for this information are found in Legal Notices