Violation of PRIMARY KEY constraint 'PK_tblSearchVaultsArchived'. Cannot insert duplicate key in object 'dbo.tblSearchVaultsArchived'
| Article:TECH62501 | | | Created: 2008-01-12 | | | Updated: 2009-01-10 | | | Article URL http://www.symantec.com/docs/TECH62501 |
Problem
Violation of PRIMARY KEY constraint 'PK_tblSearchVaultsArchived'. Cannot insert duplicate key in object 'dbo.tblSearchVaultsArchived'
Error
Violation of PRIMARY KEY constraint 'PK_tblSearchVaultsArchived'. Cannot
insert duplicate key in object 'dbo.tblSearchVaultsArchived'.
The statement has been terminated.
Solution
ROOT CAUSE ANALYSIS:
- Multiple searches are run in a department with both Automatically accept results and include items already in review options checked. Some of the searches get stuck in accepting mode and primary key constraint error is produced in Event log.
TROUBLESHOOTING STEPS:
- Unique index on the items table was recreated without the ignore duplicates flag, which results in errors being raised when duplicate items are inserted into the table instead of a warning.
FILES UPDATED
=============
None
Accelerator Hotfix File Installation Instructions
============================================================
1. Before installing this Hotfix, stop "Enterprise Vault Accelerator Manager Service" from the Services control snap-in depending on what product you are patching ( Start.. Administrative Tools.. services..) and backup the database.
2. Open Query Analyzer or Management Studio and run the following Sql scripts against the Accelerator database. ...\Files\ETrack1139388.sql
3. Restart "Enterprise Vault Accelerator Manager Service" from the Services control snap-in.
Accelerator Hotfix File Removal Instructions
============================================================
1. Stop "Enterprise Vault Accelerator Manager Service" from the Services control snap-in depending on what product you are patching ( Start.. Administrative Tools.. services..) and backup the database.
2. Restore database from backup
3. Restart "Enterprise Vault Accelerator Manager Service" from the Services control snap-in.
- Multiple searches are run in a department with both Automatically accept results and include items already in review options checked. Some of the searches get stuck in accepting mode and primary key constraint error is produced in Event log.
TROUBLESHOOTING STEPS:
- Unique index on the items table was recreated without the ignore duplicates flag, which results in errors being raised when duplicate items are inserted into the table instead of a warning.
FILES UPDATED
=============
None
Accelerator Hotfix File Installation Instructions
============================================================
1. Before installing this Hotfix, stop "Enterprise Vault Accelerator Manager Service" from the Services control snap-in depending on what product you are patching ( Start.. Administrative Tools.. services..) and backup the database.
2. Open Query Analyzer or Management Studio and run the following Sql scripts against the Accelerator database. ...\Files\ETrack1139388.sql
3. Restart "Enterprise Vault Accelerator Manager Service" from the Services control snap-in.
Accelerator Hotfix File Removal Instructions
============================================================
1. Stop "Enterprise Vault Accelerator Manager Service" from the Services control snap-in depending on what product you are patching ( Start.. Administrative Tools.. services..) and backup the database.
2. Restore database from backup
3. Restart "Enterprise Vault Accelerator Manager Service" from the Services control snap-in.
Attachments
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| Source | Event ID |
| Value | 287 |
| Description | Cause:Violation of PRIMARY KEY constraint 'PK_tblSearchVaultsArchived'. |
Legacy ID
307437
Article URL http://www.symantec.com/docs/TECH62501
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