Error: "Failed to open the disk: Cannot access a SAN/iSCSI LUN backing this virtual disk" occurs when backing up a virtual machine.

Article:TECH63541  |  Created: 2010-01-30  |  Updated: 2013-04-08  |  Article URL http://www.symantec.com/docs/TECH63541
Article Type
Technical Solution



Issue



Error: "Failed to open the disk: Cannot access a SAN/iSCSI LUN backing this virtual disk" occurs when backing up a virtual machine.


Error



0xe000954c - An error occurred while running the VMware 'vcbMounter' command to back up a virtual machine. See the job log for details.

Attempt to backup a Virtual machine may fail with the above mentioned error  message. And the job log under 'Backup Set Detail Information' shows the following message:

Backup of the virtual machine 'Test' failed. VMware VCB framework reported the following error Error: Failed to open the disk: Cannot access a SAN/iSCSI LUN backing this virtual disk. (Hint: If you are using vcbMounter you can use the option "-m ndb" to switch to network based disk access if this is what you want.) If you were attempting file-level access, stop the vmount Service by typing "net stop vmount2" on a command prompt to force vmount to re-scan for SAN LUNs and re-try the command.

Cause



This error may be encountered in any of the scenarios listed below:
 
Scenario A:

A virtual machine is selected for backup does not reside on SAN and the and the transport mode is set to SAN -Backup up virtual disk files that reside on a shared fibre channel or on an ISCSI storage device.
 
Scenario B:

The virtual machine selected for Backup resides on SAN ,VCB proxy server is attached to the SAN and the transport mode is set to SAN -Backup up virtual disk files that reside on a shared fibre channel or on an ISCSI storage device.
 
Scenario C:

The SAN LUNs are not correctly configured per VMware Consolidated Backup requirements specified in the Virtual Machine Backup Guide:

http://www.vmware.com/support/pubs/vi_pubs.html - Select the corresponding version of ESX and Virtual Center and look for "Virtual Machine Backup Guide" under "Main Documentation Set".

Solution



For setup described in scenario A follow the steps below:

1. Modify the Backup Job Properties and select Settings, VMware Virtual Infrastructure.

2. Click the drop down menu for the VMDK export file format and change the transport mode to NBD Do not encrypt the virtual disk data for over- the- network transfers as shown in (Figure 1).
 
Figure 1:

 
 
For setup mentioned in scenario B follow the steps below:

1. Open Command Prompt (Start->Run->CMD->OK).
2. Type Net Stop Vmount2.
3. Net Start Vmount2 to start the Service. This will Force vmount to re-scan for the SAN LUNs.
 
To verify if scenario C applies, follow the steps below on the VMware Consolidated Backup (VCB) Proxy Server:
 1. Open Disk Management (Start->Run->diskmgmt.msc->OK).
 2. Verify that the Disk Management console resembles (Figure 2). (That the SAN LUNs are being presented to the VCB Proxy appropriately).
 3. If Disk Management console does not resemble (Figure 2), please contact the SAN Hardware Manufacturer for assistance in configuring SAN LUNs to be presented with the same LUN ID to the ESX server and the VCB Proxy Server per VMware documentation.
 
Figure 2:


Supplemental Materials

SourceError Code
Value0xe000954c
Description

An error occurred while running the VMware 'vcbMounter' command to back up a virtual machine.


SourceUMI
ValueV-79-57344-38220
Description

V-79-57344-38220 - Backup of the virtual machine 'SERVERNAME' failed. VMware VCB framework reported the following error



Legacy ID



308860


Article URL http://www.symantec.com/docs/TECH63541


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