Restore of an Oracle 11g database fails with the RMAN error "ORA-01589: must use RESETLOGS or NORESETLOGS option for database open"
| Article:TECH65197 | | | Created: 2008-01-17 | | | Updated: 2010-01-23 | | | Article URL http://www.symantec.com/docs/TECH65197 |
Problem
Restore of an Oracle 11g database fails with the RMAN error "ORA-01589: must use RESETLOGS or NORESETLOGS option for database open"
Error
Final error: 0xe0000340 - The Database script returned an error. Refer to the Database script output section in job logs for more details.
Solution
Restore and
recovery of an Oracle 11g database using online redo logs may fail with the
above error. The RMAN Output section of the job log reports the
following:
RMAN-00571:
===================================
RMAN-00569:
=============== ERROR MESSAGE STACK FOLLOWS =
RMAN-00571:
==============================================
RMAN-03002:
failure of alter db command at 07/29/2008
ORA-01589:
must use RESETLOGS or NORESETLOGS option for database open
Cause:
Backup Exec
fails to open the Oracle 11g database that is in NOARCHIVELOG mode during
restore.
Workaround:
Run either of
the following commands from the SQLPlus prompt:
1. If the redo
logs were valid and the recovery using redo logs was successful, run the
command:
alter
database open noresetlogs;
2. If the
recover database command using redo logs failed, run the
command:
alter
database open resetlogs;
Symantec
Corporation has acknowledged that the above-mentioned issue is present in the
current version(s) of the product(s) mentioned at the end of this article.
Symantec Corporation is committed to product quality and satisfied
customers.
There are
currently no plans to address this issue by way of a patch or hotfix in the
current or previous versions of the software at the present time. This issue may
be resolved in a future major revision of the software at a later time. However,
this particular issue is not currently scheduled for any release. If you feel
this issue has a direct business impact for you and your continued use of the
product, please contact your Symantec Sales representative or the Symantec Sales
group to discuss these concerns. For information on how to contact Symantec
Sales, please
see http://www.symantec.com
Please be
sure to refer back to this document periodically as any changes to the status of
the issue will be reflected here.
|
|
| Source | Error Code |
| Value | 0xe0000340 |
| Description | The Database script returned an error. Refer to the Database script output section in job logs for more details. |
| Source | ETrack |
| Value | 1373366 |
| Description | RMAN:Ora11g:Restore job of database using 'Tablespace' node fails if database is in NOARCHIVELOG |
Legacy ID
314480
Article URL http://www.symantec.com/docs/TECH65197
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