Core Product Installation: Setup closes immediately after starting the Backup Exec for Windows Servers installation process

Article:TECH65886  |  Created: 2010-01-28  |  Updated: 2012-02-10  |  Article URL http://www.symantec.com/docs/TECH65886
Article Type
Technical Solution

Product(s)

Problem



Core Product Installation: Setup closes immediately after starting the Backup Exec for Windows Servers installation process


Error



ERROR: Installation failed with error 2.

MSI log shows Transform error -2147287037


Solution



 
Below is an example of a failed install log:
 
D:\CDRom\WINNT\INSTALL\BE\setup.exe
CSetupApp::GetInstalledGUID
CSetupApp::LoadSetupXML
CSetupApp::ScanXML
D:\CDRom\WINNT\INSTALL\BE\Bin\Setup.xml
MSI File Name = WindowsInstaller-KB893803-v2-x86.exe
MSI Version = 3.1
MSI Package Name = Symantec Backup Exec for Windows Servers.msi
System Central Processor = 86
Product Type = SETUP_BE
Product Name = Symantec Backup Exec for Windows Servers
Current Installing GUID ={CA648C72-66AB-4652-A825-9994AB5F6D15}
Product Version = 12.0
CSetupSupport::IsValidMSIPackage
D:\CDRom\WINNT\INSTALL\BE\Symantec Backup Exec for Windows Servers.msi
{CA648C72-66AB-4652-A825-9994AB5F6D15}
{CA648C72-66AB-4652-A825-9994AB5F6D15}
Equal PID
ERROR: Installation failed with error 2.
 
Cause:
 
This can occur if a manual uninstall has been performed previously and the previous product installation information was still present in the operating system.
 
Solution:
 
In order for the install to proceed, the previous installer information will need to be removed per the following steps:
 
Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.
 
The following is a list of installer registry keys for Backup Exec 12.0 and 12.5:
 
1. Locate the key for the version of Backup Exec that is to be installed and remove the GUID Number Registry Key .
 
Symantec Backup Exec for Windows Servers  12.5 -
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\FA7FA25B3B5CCF741861DA2280CF9840  
 
Symantec Backup Exec for Windows Servers 12.0 -
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\27C846ACBA6625648A529949BAF5D651  
 
2. If the keys are not listed at the paths above, locate the installer folder on disk by performing the following steps:
a. Go to Start > Run
b. Type %systemroot%\installer and press Enter to open the installer folder
 
3. Locate the BEInstParams.prm file by performing the following steps:
 
a. Perform a search for the file BEInstParams
 
b. Rename the parent folder that contains the BEInstParams.prm file.  For example: C:\Windows\Installer\{GUID.EN_US}\BEInstParams.prm
 
4. Run the Backup Exec installation again.  If the install still closes, or the install has started and fails for a different reason, please contact Symantec Technical Support to further troubleshoot the issue.
 
 



Legacy ID



316258


Article URL http://www.symantec.com/docs/TECH65886


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