Redirecting a SharePoint content database appears to start overwriting the original content database if any of the SharePoint redirect information is entered wrong in the restore job or if the restore target is unavailable.

Article:TECH65929  |  Created: 2008-01-11  |  Updated: 2013-03-01  |  Article URL http://www.symantec.com/docs/TECH65929
Article Type
Technical Solution

Product(s)

Subject

Issue



Redirecting a SharePoint content database appears to start overwriting the original content database if any of the SharePoint redirect information is entered wrong in the restore job or if the restore target is unavailable.


Error



BEWS 12.5 Job Log errors:

Restore V-79-57344-3844 - The media server was unable to connect to the Remote Agent on machine NEWSPS.
The media server will use the local agent to try to complete the operation.
  NOTE: The above message will only appear when the restore target server name is entered wrong or is unavailable

Restore- SharePoint - 80\Content-DB 1 (PRODUCTION\SQLSERVER\WSS_Content) V-79-57344-750 - The specified target is the same as the original location.  Review the SharePoint redirection property page. Ensure that the redirected restore destination is different from the original location.


BEWS 11d and 12.0 Job Log errors:
RestoreV-79-57344-3844 - The media server was unable to connect to the Remote Agent on machine NEWSPS.
The media server will use the local agent to try to complete the operation.
  NOTE: The above message will only appear when the restore target server name is entered wrong or is unavailable)

Restore- SharePoint - 80\Content-DB 1 (PRODUCTION\SQLSERVER\WSS_Content) - Access denied - unable to restore file WSS_Content.

Along with these error messages, the Remote Agent debug logs from the original SharePoint farm will show similar messages among the versions of BEWS:


BEWS 12.5 debug:
[5892] 12/11/08 15:03:03 redirected restore was directed to original location
[5892] 12/11/08 15:03:03 Error: CreateObj returns extended error e00002ee

BEWS 11d and 12.0 debug:
[3796] 12/11/08 10:11:52 redirected restore was directed to original location
[3796] 12/11/08 10:11:52 redirected restore was directed to original location
[3796] 12/11/08 10:11:52 LP_ENV::MsgError: error 0xe0008488 processing object WSS_Content

 


Cause



With Backup Exec, it is possible to redirect the restore of a content database from one SharePoint farm to another. To perform this operation, a restore job is created, the content database is selected for restore from the 'Restore Selections' view, and the 'SharePoint Redirection' tab is used to configure where the database is to be restored to, Fig 1.

 
Fig 1

If any of the information is entered incorrectly in the SharePoint Redirection tab or if the target SharePoint farm server(s) is(are) inaccessible, the restore job will fail, appearing to restore to the original database.  Depending on the version of Backup Exec being used, the Job Log will show a different failure message and will show a small byte count. No data is actually restored and the original content database is left intact. Following are some examples of job log errors for these failed redirected restores.  For clarity in these error examples, the original SharePoint server is called PRODUCTION and the target for redirection is called NEWSPS.

 


Solution



Make sure that all information is accurately entered into the Sharepoint Redirection tab of the Restore Job Properties.  Also be certain that the Backup Exec Remote Agent is installed and running on all SharePoint farm servers.  The restore target SharePoint environment must be configured the same as the original and must be online.

 

Supplemental Materials

SourceUMI
ValueV-79-57344-750
Description

The specified target is the same as the original location. Review the SharePoint redirection property page. Ensure that the redirected restore destination is different from the original location


SourceETrack
Value1474444
Description

SPSV3: Redirecting content DB attempts to overwrite original if any redirect info is wrong or if target unavailable.

 


SourceUMI
ValueV-79-57344-3844
Description

The media server was unable to connect to the Remote Agent on machine.



Legacy ID



316321


Article URL http://www.symantec.com/docs/TECH65929


Terms of use for this information are found in Legal Notices