Restore of a Exchange mailbox from GRT based backup fails with the error "Access is denied." or “-4005 Read/write access is not supported on compressed files”

Article:TECH66306  |  Created: 2008-01-25  |  Updated: 2014-01-08  |  Article URL http://www.symantec.com/docs/TECH66306
Article Type
Technical Solution

Product(s)

Subject

Issue



Restore of a Exchange mailbox from GRT (Granular Recovery Technology) based backup fails with the following errors: 


Error



"0xe0008488 - Access is denied."or -4005 Read/write access is not supported on compressed files” error pops up when trying to browse RESTORE selection list.

Granular restore of a Exchange mailbox  fails with the error "0xe0008488 - Access is denied."
------------------------------------------------------------------------------------------------------------------------------
 
Beremote Debug Log from the Backup Exec server shows:
JetExternalRestore(2) - ERROR::RC = -4005 - -4005 Read/write access is not supported on compressed files.
Using EDB Provider for Browse/Backup.
Logon: m_lpMAPISession->Logon returned 80004005
OPEN DATABASE FAILED: -4005 Read/write access is not supported on compressed files.
MB2_Chgdir:Logon returned e000fea9
 
Pop-up Error on browsing selection list shows:
"-4005 Read/write access is not supported on compressed files"

Cause



This error occurs:

  • If the data was backed up to a tape and the specified staging path points to a compressed drive.
  • If the temporal folder BE uses when handling GRT files is compressed or on a compressed drive (regardless if resulting backup is or is not in a compressed medium).

Solution



Move the staging location to an uncompressed drive or make sure the current staging location/drive are does not have compression enabled.
 
Note: The staging location for a GRT restore must be a local disk on the Backup Exec server. This disk must also be formatted in NTFS.
 
1. Go to the Properties of staging location folder, from the General tab - click Advanced (Figure 1)
Figure 1:
 
2. Uncheck "Compress contents to save disk space" option (Figure 2)
Figure 2:
 
3. If the volume is compressed - Open My Computer - Go to properties of the drive containing the staging location - Under General tab uncheck "Compress drive to save disk space" (Figure 3
Figure 3:
 
For more information on changing the staging location, please refer to "Related documents" section.

Supplemental Materials

SourceError Code
Value0xe0008488
Description

  Access is denied


SourceUMI
ValueV-79-57344-759
Description

Unable to complete the operation. The following error was returned when opening the Exchange Database file: '-4005 Read/write access is not supported on compressed files



Legacy ID



316917


Article URL http://www.symantec.com/docs/TECH66306


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