When a Vault Store Partition of Symantec Enterprise Vault is located on a mount point, restore jobs may fail with error "0xe00084bc - Directory is not empty".

Article:TECH66796  |  Created: 2009-01-16  |  Updated: 2012-11-16  |  Article URL http://www.symantec.com/docs/TECH66796
Article Type
Technical Solution


Environment

Issue



When a Vault Store Partition of Symantec Enterprise Vault is located on a mount point, restore jobs may fail with error "0xe00084bc - Directory is not empty".


Error



0xe00084bc - Directory is not empty.

Restore- EV-PTN::\\\\ @:
Directory is not empty.
Error writing file data.


Cause



When a Vault Store Partition of Symantec Enterprise Vault is located on a mount point, restore jobs may fail with "0xe00084bc - Directory is not empty" error.

This would occur when the following conditions are met:
 
  • The Vault Store Partition of Symantec Enterprise Vault is located under a mount point which is being mounted by an another disk.
  • The directory for the Vault Store Partition is not empty.
Cause:

Backup Exec performs the following operations to restore the mount point under this condition:
 
1. Check if the mount point or the directory is empty to prevent the files from getting deleted..
 
2. Delete and re-create the mount point or the directory if it was empty.
 

If the mount point or the directory is not empty at the step 1, Backup Exec reports the error mentioned above.
This is merely an warning message and can be ignored.  All of data is completely restored.
 

Solution



Resolution:
This issue has been fixed in Backup Exec 2010.

Workaround:
Please ignore it.

 

Supplemental Materials

Value1502830
Description

EV Agent: Preserve existing junction points option does not take effect on EV agent


ValueV-79-57344-33980
Description

Directory is not empty



Legacy ID



317627


Article URL http://www.symantec.com/docs/TECH66796


Terms of use for this information are found in Legal Notices