'ODBC access error' occurs after upgrading Backup Exec and/or selections are missing in the Restore Selections window.

Article:TECH67271  |  Created: 2009-01-28  |  Updated: 2014-07-07  |  Article URL http://www.symantec.com/docs/TECH67271
Article Type
Technical Solution



Issue



'ODBC access error' occurs after upgrading Backup Exec and/or selections are missing in the Restore Selections window.


Error



ODBC access error. Possible lost connection to database or unsuccessful access catalog index database.

Symptoms:

1. ERROR: ODBC access error. Possible lost connection to database or unsuccessful access catalog index database
2. Blank restore selection list.

Cause



This error usually occurs after an upgrade. It is most common among "multi-step upgrades." For example, upgrading from 9.1 > 11d > 12.5 OR 10d > 12.0 > 12.5. Multiple alerts and notifications regarding the catalogs are seen in the Windows Event Viewer and the Backup Exec Alerts tab


Solution



Following troubleshooting steps can be tried to resolve the issue:
 
You can make a copy of the Catalogs folder as a precautionary measure. For that, from the Backup Exec interface go to Tools, Backup Exec services and click Stop all services to stop all services. Make a copy of the Catalogs folder located under (default location) C:\Program Files\Symantec\Backup Exec\. Once created the copy, then start all Backup Exec services.
  1. Create a new Catalogs folder and run Catalog job with 'Storage media based catalog' option:

 

  1. Rename the existing Catalogs folder to Catalogs.old, and restart all Backup Exec Services, this will create a new empty Catalogs folder in the default location.
  2. Lauch the Backup Exec console and go to Tools, OptionsCatalogs and uncheck use ''storage media based catalog''.
  3. Run Catalog job on all media that are needed for the backup or restore job. This may take some time, depending on the media size that is getting catalog.

If the new catalogs job complete successfully, users can continue with newly created Catalogs folder. Since the actual (old) Catalog folder got renamed, all the previous Catalogs (Restore view) will not be available. To restore from all the previous backups, user will require to run the Catalogs job first on the media.

  1. If the original Catalogs folder location was not in default location, like some other drive or path, users can change the location of Catalogs folder to another volume using Beutility. For more details on how to change location of catalogs refer to the link below:
  1. If the issue persist, or users want to try rectifying the existing Catalogs, they can run the 'CatRebuildIndex -r' command as per following steps:

Open the Windows command prompt, change directory to Backup Exec installation directory \Program Files\Symantec\Backup Exec\ and run the command "catrebuildindex -r". The command will look as follows:

C:\Program Files\Symantec\Backup Exec\catrebuildindex -r

 

Note: For BE 2012 version, kindly read the following articles before running catrebuildindex command.

www.symantec.com/docs/TECH190352

www.symantec.com/docs/TECH183040

 

Additional Information for SAN SSO environment setup:

Ensure the value of the following registry keys are as mentioned below.(Depending on the Backup Exec Server configuration)

Warning: Incorrect use of the Windows Registry Editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.
 
HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Backup Exec For Windows\Backup Exec\Server
HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Backup Exec For Windows\Backup Exec\Catalogs
 
I. For a Standalone Backup Exec server
SSOState=0
Catalog Remote Server Name = (Does not exist)
II. For a SSO Primary server:
SSOState=1
Catalog Remote Server Name = (Does not exist)
III. For a SSO Secondary server:
SSOState=2
Catalog Remote Server Name = (Name of primary server)

 


Supplemental Materials

SourceError Code
ValueE0008445
Description

ODBC Access Error.  Possible lost connection to database or unsuccessful access to catalog index in the database.

 


SourceUMI
ValueV-79-57344-33861
Description

ODBC Access Error.  Possible lost connection to database or unsuccessful access to catalog index in the database.

 



Legacy ID



318287


Article URL http://www.symantec.com/docs/TECH67271


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