Drive(s) does not appear in Backup Exec System Recovery or Symantec System Recovery, that appears in Microsoft Windows Disk Management.

Article:TECH68773  |  Created: 2009-01-16  |  Updated: 2013-08-29  |  Article URL http://www.symantec.com/docs/TECH68773
Article Type
Technical Solution


Issue



C:\ Drive does not appear in the Backup Exec System Recovery (BESR) or Symantec System Recovery (SSR) console.


Error



The file PartInfo.txt may have the following warning(s): 

  • WARNING: Partition above extends beyond end of disk   
  • WARNING: Partition above overlaps with primary partition 
  • WARNING: Invalid Begin CHS values in partition above.
  • WARNING: Begin CHS does not match start sector LBA in partition above.
  • WARNING: Invalid End CHS values in partition above.
  • WARNING: End CHS does not match calculated end LBA in partition above.                 
  • WARNING: Logical partition above begins outside of extended partition.
  • WARNING: Logical partition above ends outside of extended partition
  • WARNING:  GPT Header Check Sum is invalid.
  • WARNING:  GPT Partition Array Check Sum is invalid.

Note:  The preceding are just examples of partiton table errors that may be seen in the PartInfo.txt.  Other "WARNING" messages may also exist which prevent the drives from being seen by SSR.

 


Cause



The cause of the incorrect partition table entries can include, but are not limited to:

1. Under RAID configuration begin CHS does not match start sector LBA

2. Partition size extends beyond the end of disk

BESR and SSR are sector-based backup utilities relying on completely accurate partition information in the partition table, ensuring a reliable backup of all sectors. If the software detects any partition table entry errors for any drive/volume, it will not display that volume in the GUI, as it is not viable for backup. Restoring an inaccurate volume could loss or corruption. This is working as designed, and there is no way to disable the safety feature.


Solution



If a drive does not appear in the graphical user interface (GUI)  as drive to back up, run the PartInfo utility to create a partition table report. The default location of the PartInfo utility is as follows:

For 32-bit systems:

C:\Program Files\Symantec\Backup Exec System Recovery\Utility

For 64-bit systems:

C:\Program Files (x86)\Symantec\Backup Exec System Recovery\Utility                

 

NOTE: The path names for BESR 2010 will appear as Backup Exec System Recovery, and the path names for SSR 2011, and SSR 2013 will appear as Symantec System Recovery.

The output file PartInfo.txt will be created in the same directory. You can review this PartInfo.txt file to identify above mentioned warnings that causes the drive visibility issues in Backup Exec System Recovery, or Symantec System Recovery.

To resolve the drive visibility issue, do the following:

  1. Reboot your computer, and enter into the system BIOS. Check the drive settings for accuracy. Ensure that you can detect the drive correctly. If necessary, let the BIOS  re-detects the required drives.  Contact the system or motherboard manufacturer of your computer for further help and assistance.
     
  2. If any partitions exist on a NAS or SAN device, ensure that all controllers are using the latest firmwares, and drivers.
     
  3. Shutdown the server, and reinitialize the device(s).
     
  4. If your computer is running Microsoft Windows Vista, or Windows 7, or Windows 2008, or later, open the Windows Disk Management console.
     
  5. Right-click the affected volume, and choose Shrink Volume...
     
  6. Reduce the volume size (in MB). This will possibly bring the partition table boundary back into compliance. A reboot may be required after this step. After the reboot try to recreate the backups. Check the drive(s) visibility .
     
  7. If the drives are still not visible, rerun the PartInfo.txt file. If the warnings still appear, use the Shrink Volume...  option under Windows Disk Management, until the warning is not seen in the PartInfo.txt file.
  8. If an legacy BESR or SSR backup exists, boot to the SRD.
     
  9. Delete the existing volume(s) that are with errors, and restore them from within the SRD.
     
  10. If drives are still not detected, the only solution is to backup the data using a file-based backup using the Backup feature of Microsoft Windows or  Backup Exec for Windows Servers (BEWS). Once your data is backed up, the partition should be deleted, and then rebuilt.
     
  11. If the partition (that needs to be rebuilt) contains a system drive, a reinstall of the operating system will be required. 
     
  12. After rebuilding the partition, the data can be restored from the backup. After the new partition is in place, the drives should now be detected in BESR. If Backup Exec for Windows Servers is not installed, download a trial version from  http://www.backupexec.com
     

If you have any questions or queries, contact Symantec Tech Support for further Help and Assistance.




Legacy ID



321065


Article URL http://www.symantec.com/docs/TECH68773


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