Backup Exec terminates with a .NET error when attempting to open the User Interface (UI)

Article:TECH69999  |  Created: 2009-01-27  |  Updated: 2012-04-09  |  Article URL http://www.symantec.com/docs/TECH69999
Article Type
Technical Solution

Product(s)

Problem



Backup Exec terminates with a .NET error when attempting to open the User Interface (UI)


Error




EventType clr20r3, P1 bkupexec.exe, P2 12.5.2213.0, P3 48c5e5ec, P4 bkupexec, P5 12.5.2213.0, P6 48c5e5ec, P7 66, P8 1d, P9 system.typeinitialization, P10 NIL

Event Log may show: 

Event Type: Error
Event Source: .NET Runtime 2.0 Error Reporting
Event ID: 5000

Description: EventType clr20r3, P1 bkupexec.exe, P2 12.5.2213.0, P3 48c5e5ec, P4 bkupexec, P5 12.5.2213.0, P6 48c5e5ec, P7 66, P8 1d, P9 system.typeinitialization, P10 NIL.

SGMON log shows:
 
The type initializer for 'BackupExec.UIFramework.ThemeManager' threw an exception.
 
Stack Trace: at BackupExec.UIFramework.ThemeManager.AreFontsAccessible(String&exceptionMessage)
 
at BackupExec.UI.MainForm..ctor()
 
at BackupExec.UI.MainForm.get_Instance()
 
at BackupExec.UI.MainForm.a(String[] A_0)
 
at BackupExec.UI.MainForm.b(String[] A_0)
 
Inner Exceptions:
 
Exception:System.ArgumentException
 
Font 'Arial' does not support style 'Regular'.
 
Stack Trace: at System.Drawing.Font.CreateNativeFont()
 
at System.Drawing.Font.Initialize(FontFamily family, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet, Boolean gdiVerticalFont)...
 

Cause




In this example, the issue is caused by a corrupt version of the "Arial" font within Windows. It may be possible that a different font is causing this issue. Please refer to the SGMon log for the font in question. 
 


Solution




1. Open & enable the SGMon debug utility to ensure this is the issue & to identify which font is corrupt: Default location: c:\Program Files\Symantec\Backup Exec\SGMon.exe

 
* Instructions for using the SGMon utility can be found at:  www.symantec.com/docs/HOWTO11932 
 
a. Reproduce the problem by attempting to launch the Backup Exec UI
 
b. Identify the issue & font in the live SGMon monitor or from the default log location: c:\program files\symantec\Backup Exec\Logs\Servername-SGMon.log
 
2. Uninstall the corrupt font per the following:
 
a. Navigate to Windows\fonts
 
b. Select the font and delete
 
3. Obtain the new font by copying from another server or downloading a new copy.
4. Install the new font per the following:
 
a. Navigate to Windows\fonts
 
b. From "File" select "Install new font"
 
c. Select the new font file and install


Supplemental Materials

SourceEvent ID
Value5000
Description

EventType clr20r3, P1 bkupexec.exe, P2 12.5.2213.0, P3 48c5e5ec, P4 bkupexec, P5 12.5.2213.0, P6 48c5e5ec, P7 66, P8 1d, P9 system.typeinitialization, P10 NIL



Legacy ID



323740


Article URL http://www.symantec.com/docs/TECH69999


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